Taurus Car Club of America : Ford Taurus Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
Some one please help. Make long story short. fuel pump died on me. found out fuel pump is good and that it is infact the fuse link B that feeds 12V to the ICM. My question is where is the fuse link that sends 12v to ICM. I have looked underneath the powerdistribution box and are still having a tough time locating it. Any help would be greatly appreciated. If I am not at work tomorow my job goes bye bye lol.
 

·
Registered
Joined
·
81 Posts
Discussion Starter #2
Just to further assist you in answering my question The ICM feeds 12 V to the fuel pump via inertia switch. But I am assuming anyone who has the knowledge to answer my question would already know that. Once again, any help would be more than appreciated.
 

·
Premium Member
Joined
·
2,090 Posts
More likley, you being in the northeast, it is a corroded wire to the ICM not the fusable link. Ive dealt with this problem several times. Test the power to the ICM, if there is none or the reading is less than 11.5v, then you need to run a new power wire.

Bob just fixed this exact same issue on a gen 2 wagon. Fuel pump was getting some power, but not enough because the wires were all corroded.

Brad
 

·
Registered
Joined
·
81 Posts
Discussion Starter #4
Ok I'll try that next. What I have been doing is replacing the little 10 amp fuse every 10 miles or so (everytime it gets blown). Just so I have this right, The power going in to the ecm is coming from the PDB right? Also there is a wiring harness about midway inbetween the PDB and the ECM the cuts the wire and changes its color. Instead of finding little pin adapters that connect the wire to the harness can I just run a wire strait from the ECM to the PDB. Any help would be appreciated. Its at the point were I got serious hesistation everytime I hit the gas and I just want to make sure when I rewire it that I am getting all 12v across. I cant run the wire through the harness because I dont have any of those little pins that pop into the harness. thanks again.
 
1 - 4 of 4 Posts
Top