Taurus Car Club of America : Ford Taurus Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 96 GL sedan. It does have a 3.0L OHV i think. Im not sure what type of transmission it has, but here are the problems.

First, recently right after i started it would not come out of park, so i shut it off and waited then tried again and it still didnt work. Then without shutting it off i waited again and it worked fine.

then, normally when shifting from R to D it "feels" as though it slams and the car lurches forward.

Next, a couple times when i was driving it felt as though it went into neutral and it took me shifting through park and neutral and drive a couple of times for it to reengage.

Finally, when coming to a complete stop it feels like it goes into park because when i take my foot off the brake it doesnt move at all, but when it does go it slams pretty hard.

Im just assuming that is the transmission.
 

·
Registered
Joined
·
211 Posts
Transmission flushes are very, very bad. Take it to the shop that did the flush and make them fix it. I am serious.
I agree man. Flushes if done not using the trany's pump could easily blow out the seals. Fluid and filter changes are the best bet for a neglected transmission to slowly get the fluid out.

my bull is in the shop for the same transmission issue it lurched like that and then the next day it completely ate itself and died. Sorry dude but it sounds like your transmission needs to be rebuilt. Check the fluid just to be safe though.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top