Taurus Car Club of America : Ford Taurus Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
My wife and I own a 99 Sable GS with a 3.0 DOHC. Just before Thanksgiving, the battery light came on along with some other lights (ABS, Air Bag) one night when my wife was coming home from school. The lights flickered and eventually went out, and the car seemed to actually idle fast and was able to make it up a steep hill without using the accelerator.

I took the car to Sears and they ran an electrical test on the car and determined that that the alternator was bad which had drained the battery enough to go bad. They replaced the alternator, battery and belt (it was old and had cracks) and we are still experiencing the battery light coming on. We've had the car back for about two weeks and the light is not always on when you first start the car, but after about 10 - 15 minutes of driving it comes back on. The interior lights and headlights also flicker at times when as well as the battery light and any other electrical device will vary in operation (blower will not blow at a constant speed at times when the lights flicker). Now, it seems that the car is having an erratic idle when the above conditions occur as well. I took it back to Sears ,but the car was not showing signs of the trouble, and they said the battery and alternator were good.

Has anybody experienced this before and have any input as to what may be causing this weird behavior?

:merc:
 

·
Premium Member
Joined
·
14,124 Posts
mn;l.'
'';';p;l';/

Sorry I was wiping pickle relish off my keyboard....

Probably still a bad alternator or the plug with the small wires isn't seated good. They may have broken off the retaining clip for the connector when they removed the first alt.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Thanks for you help. I'll check out the plug with the small wires and see if it is seated good.
 
1 - 4 of 4 Posts
Top