Taurus Car Club of America : Ford Taurus Forum banner

1 - 2 of 2 Posts

·
Premium Member
Joined
·
287 Posts
Discussion Starter #1
I just ended up putting all new bulbs, (Led) in my instrument clustter. While the 5 main bulbs work fine, I am having some issues with the smaller, (#74) bulbs. 2 in particular, ABS, and Airbag. It seems that after you start the car, the bulbs will go out, but you can see that they still are slightly lit as they dont go completely out .Its not like they are fully lit, but if you look close enough you can see that both are still on...... I have tried installing them both ways, with no correction. Right before this happened, the cruise stopped working, as the light didnt come on after pressing the cruise on switch. I thought the bulb was burnt, and replaced, with no correction. I just felt maybe all this was linked together somehow. The other crazy thing is the airbag light will sometimes go out, after starting the car, other times it will stay on for awhile before it wants to go out. With all the original bulbs this was never an issue. I do know that those bulbs can only go in one way to work. I have checked all fuses for the cruise control. The Boo switch is working as I have brake lights. The clock spring is fine as the horn works. I have yet to put a meter to the servo. I broke the On/Off switch cover for the Cruise as I was going to clean the contacts, so I do have to replace that, even though the issue happened before that. I have no codes. I believe the cruise gets its signal from the VSS, although I am not having any tach or speedo issues. I have also read that the cruise has a relay somewhere, for the life of me I havent a clue where its at. Alldata or my Ford Cd tells me there is a relay, but doesnt show where. I know I am listing a few things combined, and I hope someone can makes heads or tails of what I am attemting to explain. Any ideas?
Tom
 

·
Premium Member
Joined
·
9,959 Posts
I had problems with LEDs in the instrument cluster too. I had to replace the battery light with a regular bulb because the LED would never go out. The cruise light sometimes doesn't work, and it is always very dimly lit. Brake, CEL, door, blinkers all work fine.
 
1 - 2 of 2 Posts
Top