Taurus Car Club of America : Ford Taurus Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
hi all. my LED strip on my 95 taurus spoiler for sure has failed, and according to my local ford stealership, the only recourse to get a functional 3rd brake light again is to buy a NOS spoiler for around 300 bucks. i laughed so hard at the guy i thought i was gonna cry. does anyone know of a source to get a new LED strip? granted, the sable that the spoiler is going onto has the third brake light inside the rear window, but i would prefer to have the spoiler mounted brake light to function as well. pleeeeeease help if you have any ideas!!!! thanks in advance..... john inn grand haven, mi
 

·
Registered
Joined
·
2,438 Posts
Not likely the LED's are bad, more likely it's a wiring or electical contact problem in a connector, or maybe a bad ground connection. So I'd begin by pulling the spoilers electrical connctor & checking it's pins & sockets for corrosion, or dmage, then check to see if you have power to the connector, with the brake pedal pushed.

If not, then check the spoilers wiring all the way back to the LED array. Inspect closely, anywhere the wiring bends, or is retained & flexed close by, as those bend points can cause the wire strands to work harden & break under the insulation, over time.

If you find a broken wire, just cut into it at the break pont, place a piece of shrink tubing on the wire, splice & solder it, then slide the shrink tubing over the splice & shrink in place with heat, to insulate the splice.

Let us know what you find.
 
1 - 3 of 3 Posts
Top