Taurus Car Club of America : Ford Taurus Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
today i swerved and slammed on the brakes on wet pavement to avoid a deer. I ended up in a cornfield. When i got out my RF tire was loose on its rim, i was leaking coolant and the LR wheel was leaning in at the top. I fixed everything else, but the LR tire is still messed up. It is driveable, but the tire is rubbing on the strut tower....i think.....any ideas on how to fix?
 

·
Premium Member
Joined
·
7,593 Posts
look under it to see what is bent. It can only be a few things, lower lateral arm(control arm)X2, strut rod, knucke, or strut.

[attachment=29255:rear_suspension.jpg]
 

Attachments

·
Registered
Joined
·
43 Posts
Discussion Starter #10
I'll take the wheel off tomorrow and look and then probably end up taking it to the shop. I'll let you know what i find out
 

·
Registered
Joined
·
43 Posts
Discussion Starter #11
QUOTE (c2harvey @ Apr 22 2009, 09:56 PM) index.php?act=findpost&pid=719781
I'll take the wheel off tomorrow and look and then probably end up taking it to the shop. I'll let you know what i find out[/b]

took the wheel off and everything appears ok, including the strut. I managed to bend something back by pushing down on the wheel, so it no longer rubs, but it is very close to the strut. The only thing i could see damaged was the rubber on what i think is the swaybar endlink.
 

·
Registered
Joined
·
513 Posts
QUOTE (c2harvey @ Apr 23 2009, 06:24 AM) index.php?act=findpost&pid=719871
took the wheel off and everything appears ok, including the strut. I managed to bend something back by pushing down on the wheel, so it no longer rubs, but it is very close to the strut. The only thing i could see damaged was the rubber on what i think is the swaybar endlink.[/b]
Go ahead a take some pics anyway, maybe someone will see something you don't. A pic is worth a 1000 words. ;)
 

·
Premium Member
Joined
·
14,126 Posts
The large eye where the strut rod attaches will bend and is very difficult to see.

Probably need a new hub.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #15
Got it checked out....turned out to be a bent strut, right at the pinch bolt. The lower radiator hose is also cut. I drove it home about 6 miles and it didnt leak at all and then sat for ~18 hours and still fine. Then I drive it to the garage 1 mile away and its leaking when they pull it in.
 
1 - 15 of 15 Posts
Top