Taurus Car Club of America : Ford Taurus Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
My mother N Law has an 89 tarus wagon with the 3.0 motor. I just replaced the Radiator in the car and now I can't get that top tranny line to stop leaking. It isn't coming out the threads, just out the back of the flare nut were the medal line goes in. There appears to be a plastic clip on the inside. Does anybody know how to take this apart if possible and/or I can fix this without replacing the hole line.
 

·
Registered
Joined
·
285 Posts
Push the plastic clip in towards the radiator, and pull the trans fluid line out. It's kind of like a fuel line clip, if you've ever swapped out a fuel filter on these beasts.

There is an internal O-ring that you can dig out and replace. Any auto parts store will have the O-ring.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Thought it may have been something likr that. The clip sits up against the nut, do you squeeze it first and push in or..? I will have another look at it in a couple days and see if I can get it apart. Thanks
 

·
Registered
Joined
·
285 Posts
Push the clip in, against the body of the nut. (IIRC) No need to squeeze it.

Ford will sell you the whole fitting, that's what I did. Then once I got 'em and could see how they worked, I wished I'd just replaced the 50 cent O-ring instead of the $9 fitting. <_<
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top