Taurus Car Club of America : Ford Taurus Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey everyone, I just want to tell you how I got everything installed and show it off. Everything all together cost around $200.

I ordered a Phoenix Gold Ti15 and a no name amp (Pyramid?) off of eBay awhile ago, knowing this install would be a challenge. The first thing I did was run the power cable to the back, which was definately the hardest part. The rubber grommet was well hidden behind the brake booster, and couldn't be accessed easily from the inside without the removal of the fusebox :angry:.

Next I pulled off the left wall in the trunk, to run the remote and ground wires. For the remote, I ended up cutting off a black w/pink striped wire which was on the male end of a plug. After inspeciting it, I realized that it doesn't go to the stereo and it would be ok to just cut it off and use for my remote line. For the ground, I just put it under the same bolt that had all of the other ground lines going into it.

The next thing I did was sodder stereo wire on to each of the rear speakers. I did this only because I did not want to buy a line level converter and my amp supported line level inputs. This was very easy because there are two holes in each speaker post, one of which is taken by the speaker, leaving the other one free. I ran the wires along the rear deck and held them up using cable ties.

Finally I mounted the amp on the rear seat and hooked everything up. I tested it to see if it powered on, thankfully it did. The only problem I have is that my amp turns on with my car, and not with my stereo. It isn't that big of a deal to me so I didn't bother taking off the wall again and looking for a new remote line. I got my sub in its box and cranked it up. I'm very happy with my install, and amazed with how little it cost.

Now for the pics:
PG Ti15 and box
http://img29.imageshack.us/img29/3921/P6030002.jpg' alt='' width='800' height='600' class='attach' />[/url]

Cheapo amp
[url=http://img23.imageshack.us/img23/8921/P6030003.jpg][img]http://img23.imageshack.us/img23/8921/P6030003.jpg' alt='' width='800' height='600' class='attach' />[/url]

If anyone has any questions or comments I'd be happy to hear them!
 

·
Registered
Joined
·
370 Posts
Don't forget to run 20 hours of music at lower volumes to the sub to break it in. Anyways, how does the sub perform?
 

·
Premium Member
Joined
·
500 Posts
Nice job. I'm in the process of removing my stereo equip from my truck to install it my Bull. It isn't easy though with a 10 month old. She's sitting on my lap right now chewing on my cell phone.
 
G

·
Looks good! :thumb: Nice choice on a sub, too! I have two Phoenix Gold 12's and am very happy with them. Enjoy! B)
 
1 - 4 of 4 Posts
Top