Taurus Car Club of America : Ford Taurus Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
My battery has been draining rapidly Ive gone through four in a couple months because I have to recharge them so much. I changed out my alternator, belt, checked all the wiring and fuses, and nothing has seemed to work. But I recently noticed that my Control panel is hot to the touch around the display areas for the radio and the climate control even after the car has been off and sitting over night and that they are actually glowing with a red light in rows of lines from left to right. Ive searched google and yahoo and can't find any info on the problem I was hoping someone here could illuminate me as to what this is. I'm thinking this might be what is killing my batteries. Any info at all would be greatly appreciated. Thanks in advance.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Ive looked every where I cant find anything. Ive even had it hooked up to several diagnostics computers and they all say there is no drain on the battery after the car is off. :\
 

·
Registered
Joined
·
23,349 Posts
Maybe change out the icp with one from a pick n pull. I had a similar problem with the cassette motor constantly running trying to eject a stuck tape that i had previously removed in pieces. Salvage yard icp was $20-30, iirc and that was the auto eatc one.
 

·
Cake monster
Joined
·
1,584 Posts
My battery has been draining rapidly Ive gone through four in a couple months because I have to recharge them so much. I changed out my alternator, belt, checked all the wiring and fuses, and nothing has seemed to work. But I recently noticed that my Control panel is hot to the touch around the display areas for the radio and the climate control even after the car has been off and sitting over night and that they are actually glowing with a red light in rows of lines from left to right. Ive searched google and yahoo and can't find any info on the problem I was hoping someone here could illuminate me as to what this is. I'm thinking this might be what is killing my batteries. Any info at all would be greatly appreciated. Thanks in advance.
Well, I would be pulling the battery while I'm not using the car if I were you, unless you want the car to melt itself into something new :D

Sounds like a bad short in the ICP, if it isn't to do with the harness and you don't know much about opening electronics, I would head to a picknpull to get another one, like mentioned above. It must be pretty uncommon. I wouldn't trust it at all, even if it stopped doing it. Just get a new one, it isn't worth the fire hazard. Hopefully it isn't a short somewhere else in the car.
 

·
Premium Member
Joined
·
7,307 Posts
IIRC, get the icp from a 96 or 97 model, as the 98-99 ones were different??
 

·
Cake monster
Joined
·
1,584 Posts
^ Yes, durasel, iirc, the elec. and vac. conn. is a little different on 96&97 vs 98&99?
I'm not sure of the difference, I know I used a good part of the wiring harness from a 97 in my 99, but I think I left the vac part alone.

Edit: come to think of it, the icp was also from a 96 and I didn't have it hooked up until I spliced the 97 wiring harness in, and I needed a new harness because the previous owner butchered it. So you can make them work with some modification I guess.
 

·
Devoted Member
Joined
·
2,426 Posts
Ive looked every where I cant find anything. Ive even had it hooked up to several diagnostics computers and they all say there is no drain on the battery after the car is off. :\
Sometimes those "diagnostic computers" aren't worth a f***. Hook up a DMM that will read current in series between your battery Neg. terminal and the Neg. cable. You will probably see plenty of current flow (voltage drain).
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #12 ·
Sometimes those "diagnostic computers" aren't worth a f***. Hook up a DMM that will read current in series between your battery Neg. terminal and the Neg. cable. You will probably see plenty of current flow (voltage drain).
That's what I had done and the only pull on it was minute. I was leaning towards replacing the whole ICP i just have to find one. I would like the thank everyone for all their help and info. It does fine if i drive the car every day but if it stays parked for two or three days it goes dead.
 
1 - 12 of 12 Posts
Top