Taurus Car Club of America : Ford Taurus Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I need to replace bulbs in the instrument panel but I can't seem to find a diagram or tutorial for the 95' SHO. The other tutorials etc. are on different Taurus models and years. I have taken the large section under the steering wheel off, the 2 bolts just beyond the steering wheel, as well as above the instrument panel. I seem to be stuck now and any help will be welcome.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Upper Dash

I viewed those pictures and instructions as well but it appears that my upper dash above the radio unit that houses the temperature controls is different as he was working on a 1991
 

·
Registered
Joined
·
17 Posts
I viewed those pictures and instructions as well but it appears that my upper dash above the radio unit that houses the temperature controls is different as he was working on a 1991
Yeah it's definitely a little different for genII, but it should still be able to come off. To be completely honest I had to look at both the Haynes and Ford factory instructions in order to do mine, so investing in the Haynes book (if you don't have it already) may be a good idea.

I'll actually be doing the procedure again soon (to replace some bulbs, I really should have put in a brand new set when I did the cluster swap...), I'll try to get some clearer pictures of the procedure at that point.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Panel Lights

Thank you, I will try and get my hands on one of those books any pictures will be helpful. Thanks again.
 

·
Registered
Joined
·
17 Posts
regarding the link for the gen I, are the 5 sockets on the left side bottom of the pic and the 6 on the right for the idiot lights? (Oil, brake, CEL, etc?)
Yep, same bulbs / sockets for both the idiot lights and the illumination lights IIRC so it doesn't even really matter if you plan to do them all. Never seen a SHO's cluster myself, so there may be "high end" extras in there with different bulbs (stuff like "LOW COOLANT", "LAMP OUT", "LOW OIL" etc. that my GL does not have).
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Fixed

Today I got the bulbs in behind the instrument cluster and figured everything out however I now have a new problem none of my windows will roll up or down
 

·
Registered
Joined
·
17 Posts
Today I got the bulbs in behind the instrument cluster and figured everything out however I now have a new problem none of my windows will roll up or down
By new do you mean newly discovered, or were they working before you pulled the cluster? If the latter, I have no idea how the cluster could affect the power window circuits but it's not impossible I guess.

Have you tried from both the master switch and the individual switches? Do you hear a "click" at all when you try to move a window? Have you checked the fuse (fuse number for power windows will be in your owner's manual, but in my 93 the power windows are shared with several other things so if everything else works the fuse probably is good).

If all the basic tests fail you'll want to pull the master switch (easy to remove, just two screws IIRC) and check for a good connection, if you have a multimeter try to make sure it has good power and ground.

Wiring diagrams can be found online, or if you managed to get a copy of the Haynes manual that also has most (but not all) wiring diagrams included.
 

·
Registered
Joined
·
11 Posts
the key has to be turned on for the windows. the power the key turns on goes thru the steering columns connectors. check and reset all the connectors you were near, especially the big one that probably has blackened areas from excessive heat.
 
1 - 10 of 10 Posts
Top