Taurus Car Club of America : Ford Taurus Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
:eek: HELP! My instrument panel lights are out. (Only the lights behind the speedo, tach, fuel & temp gauge). Radio, A/C and warning lights all work. All fuses ok. Checked with dealer, no clue but happy to investigate @ $83.40 an hour. Estimated 1 to 4 hours.
 

·
Registered
Joined
·
702 Posts
Originally posted by DB3@Aug 30 2004, 12:45 PM
:eek: HELP! My instrument panel lights are out. (Only the lights behind the speedo, tach, fuel & temp gauge). Radio, A/C and warning lights all work. All fuses ok. Checked with dealer, no clue but happy to investigate @ $83.40 an hour. Estimated 1 to 4 hours.
Never go to the dealer unless its a last resort. They would charge you for the chair you sit in while you wait if they could. Your best guess would be to see if the light bulbs are just out. Maybe something blew them. Theres also two connectors that each have about 10 or more wires on them that connect to the dash panel- theres a chance that a wire is just lose or something.
 

·
Registered
Joined
·
517 Posts
ya it is not so bad i replaced all my bulbs this weekend the hardest part is takeing out the radio... other than that it is not to scary of a task

good luck
 

·
Registered
Joined
·
157 Posts
Make sure you check the fuses under the hood too. This happened to my friend's '99 and it was one of the fuses under the hood.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
:blink: Got everything taken apart and the lights came on. Must be a short. Thanks for all the help guys. I can see again! :banana:
 

·
Registered
Joined
·
135 Posts
db3, could you tell us a little more what you did there to get your
lites to come back on? did you have to take the whole dash board
panel out? were your gauges functioning properly?
i have 1/3 of the speedo lite out, 2/3 ok, and also my fuel guage
works about everyother day, so i keep trac of miles.
thanks, dave
 
1 - 7 of 7 Posts
Top