Taurus Car Club of America : Ford Taurus Forum banner

21 - 24 of 24 Posts

·
Registered
Joined
·
7,221 Posts
Seems hard to believe that both the IAC and the MAF go bad at one time. You really need to resolve the missing issue before replacing the MAF. Sparkplugs and wires are a good start. Don't need to replace them but you need to remove plugs and look at them and the gap. Then you need to at least measure the resistance of each plug wire.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #22
Why do you think the idle speed is too low? What is the rpms?
wow to d
Seems hard to believe that both the IAC and the MAF go bad at one time. You really need to resolve the missing issue before replacing the MAF. Sparkplugs and wires are a good start. Don't need to replace them but you need to remove plugs and look at them and the gap. Then you need to at least measure the resistance of each plug wire.
i did take it to shop ,, there was 2 stored codes,, one was low voltage to my MAF sencor,, and the other was a IAC code,,i just hope its not a computer problem ,, or a bad ground,,yesterday it idled better driving the cart,,, it had a low idle it was not missing that bad ,, today it had a low idling and i can feel the miss at motor at idling,,, when it was warmed up, one day the transmission had a harsh shift into 2nd gear doesnt do that all the time,,,, now thinking it might not have been the problem with the IAC and MAF,,iam thinking more of a bad throttle position sencor,,,,, its has a ruff low idle acting like somtimes it was going to die at a stop light,, then steping on the gas and driving slow i feel the miss in the motor ,,, then going faster i cant feel the miss it goes away and takes off like a rocket with no hesitation and theres no check engine light, it is using more gas,, trying to get my car scoped out at a ford dealer which only charges 50 dollars , there booked out i did make appointment,, cheaper then lot of other places,, and mine is a 97 mercury sable LS , DOHC i had the car over 20 years with only 131,000 miles on it now,,,,, on my car,also thinking about tuning it up again i had it done in 2003 at 99,000 miles,,
 

·
Registered
Joined
·
23,283 Posts
For the miss, may suspect plugs, wires, coil pack, then injectors and finally compression/leak-down tests. Have you checked "all" the vacuum hoses/lines on the firewall side of the engine? If you remove the uim to check/replace plugs, wires or coil pack, it'd be good time to check. May also consider uim/lim gaskets.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #24
For the miss, may suspect plugs, wires, coil pack, then injectors and finally compression/leak-down tests. Have you checked "all" the vacuum hoses/lines on the firewall side of the engine? If you remove the uim to check/replace plugs, wires or coil pack, it'd be good time to check. May also consider uim/lim gaskets.
i checked the hoses didnt see and hoses loose , i sprayed motor with carb cleaner 3 times could not find any air leaks,, the car has 131,000 miles on the DOHC motor,and around 2002 the coil went bad and a shop put motorcraft coil pack and around 2003 around 98,000 miles it has a miss and it needed a tuneup plugs and wires and new manifold gasket,, i also put a new motorcraft pcv valve,,new autozone duralast MAF,, a new motorcraft IAC ,, i will have to take it a shop to get it scoped out
 
21 - 24 of 24 Posts
Top