Taurus Car Club of America : Ford Taurus Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter #1
If i had a burnt or warped Valve would it make noise and give crappy compression? I've been working on my 87 vulcan and i replaced every sensor i mean every sensor and i have new distributor plus cap rotor. I even replace the upper and lower intake gasket lifters Injector o-rings antifreeze i put in synthetic oil fuel pressure regulator fuel and air filter and i STILL get a miss upon deacceleration and the idle surges upon start and i cant get it run in the morning. I've hooked up my scan tool and i have no data and no codes. i forgot i replaced all my vacuum hoses and i get 15-20 vacuum pressure 35-40 psi fuel standard plugs and wires cap and rotor i get 165-175 pounds of compression the engine inside was clean no carbon build up .I also ran an cleaner in the fuel system. I have ran out os IDEAS this only happens sometimes when i put the car in park the backfiring goes away. the backfiring is so small that you can only feel it on your foot. You can not even hear it it is barely noticeable by the ears. The surging in the Idle happens all the time it seems to LOOK for idle I have and doubled checked the IAC and it is not the problem. I need more ideas It is also running rich I had the injectors tested and they are fine with no leaks NEED HELP PLEASE
 
B

·
Guest
Joined
·
0 Posts
If you had a damaged valve it should show up in the compression test. With those compression numbers, I doubt there's anything wrong with the mechanicals of the engine.

As for the other problem, I'm stumped. Seems like you've done everything you could to take care of it. I would suggest the EGR system, but the 86-90 cars didn't have an EGR (Vulcan only). Sorry I couldn't be of more help!
 

·
Premium Member
Joined
·
2,415 Posts
This is a stab in the dark, but have you ever replaced your catalytic converters? I mean, the car is 17 years old now and sometimes they clog up, especially when you run rich like you said. What about o2 sensors?
 

·
Registered
Joined
·
148 Posts
Discussion Starter #4
yea i got the o2 sensor already but i haven't replace the cat converter yet i don't want to shill out the 350 bones to have it replaced. I don't have an EGR or MAF sensor if it would of helped i would have replace it also
i have thought it was the cat myself but i was hoping it wouldn't be. well i hope to give that a shot. i know it isn't one cyclider problem cause all the plugs are running rich
 

·
Registered
Joined
·
148 Posts
Discussion Starter #5
How can i be sure that the cat is bad i don't want to spent an unessccary 350 bucks again this is a 87 and the only reason im trying to get it running properly is soo that my remote starter works
and also i just stuck 1200 into the tranny. i mean this car is going to drain me into brankrupcy but not really but close i should have just bought a new car but i told granny id keep it running as long as possible but if i cant get this working i rather junk it but if it is the cat converter i want to keep it. I REally need an autostart cold up here in minnesota
 

·
Premium Member
Joined
·
5,180 Posts
Hey Im not sure if you are interested, but I have a cat from a 1990 Taurus that was replaced under warranty (emissions recall) only used it for about 60,000kms (Genuine Ford) that I need to sell. Lemme know if you are interested.

You can try putting your foot over the tail pipe and having someone rev the engine a bit, it should easily push your foot off.

Also what is your mileage? Perhaps your camshaft is worn...
 

·
Registered
Joined
·
148 Posts
Discussion Starter #7
I replaced the lifters and while i had it apart i inspected the cam and it looked perfect had good lift and good compression i looked for broken valve springs but they had this shield around the valves so it was hard to tell. I replaced the Lifters and it fixed the rattle i had in the valve train but it still didn't fix the no start when cold or the popping im hearing when i get off the on ramp from a freeway. I only have 114k miles on it. what are you asking for the converter if it was under recall whats wrong with the one you have? in Km how many miles is that here i take it your from canada?
 

·
Premium Member
Joined
·
5,180 Posts
Are you sure you do not have defective spark plug wirse? I mean I had this problem with my 1990 vulcan (popping on the freeway) I agonized over it for three weeks, checking various things, replacing this and that, and it turned out my brand new plugwires had a couple bad ones. have you tried unplugging the spark plug wirse to see if makes a difference in how the engine runs? This is how i finally discovered that a couple wirese were bad. Have you replaced your knock sensor? Its on the back of the engine,. replaced mine but it still had the same problem of popping. There is nothing wrong with the cat I have laying around, like i said it was replaced under warranty, I used it for about 37.5k miles, I took it off because I put a straight pipe on that my buddy built for me out of an old cat. Anyways, Make me an offer if you are interested, Im not sure how much a used cat is worth. All I know is how much Ford charges.
 

·
Registered
Joined
·
148 Posts
Discussion Starter #10
Zep i am interested in the cat IM going to open her up this weekend and if it fixes the problem ill purchase it from you. I dont really want to feel like im cheating the system also will this be converter only or the y pipe assy? also what will it do if i were to leave it opened up will it be louder more power?
 

·
Premium Member
Joined
·
5,180 Posts
its the whole assembly. the hardest part of installation will be getting your old bolts out. I had a welder put a piece of pipe in the place of the converter, it made the exhaust louder, I don't really know if i gained that much power I think there was somethign wrong with the engine... But it is great if you want to make your exhaust system super loud. my exhaust was obnoxiously loud with no converter or resonator.
 
1 - 11 of 11 Posts
Top