Taurus Car Club of America : Ford Taurus Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
My fiance got a great deal on a 2000 taurus wagon from a reputable shop with about 76k originals miles,1 owner and it's pristine...after about 35 miles it seemed to get kinda slow Annnnnd barely made it home.Is it an easy common fix? PLEASE AND THANK YOU
 

·
Registered
Joined
·
186 Posts
I would start with a conversation with that "reputable shop". Why were they in possession of it initially? What work/diagnostics did they do on it...if any? Solutions to problems like loss of power are seldom easy; nor, common. More information is needed in order for members here to help. Which engine does it have...Vulcan or DOHC?
 

·
Registered
2001 Taurus SES Sedan in Chestnut
Joined
·
59 Posts
I would start with a conversation with that "reputable shop". Why were they in possession of it initially? What work/diagnostics did they do on it...if any? Solutions to problems like loss of power are seldom easy; nor, common. More information is needed in order for members here to help. Which engine does it have...Vulcan or DOHC?
And also is the Check Engine Light (CEL) blinking? If so you are in safe mode.
 

·
Registered
Joined
·
67 Posts
76k on a 2000 = rare. Worth having a knowledgable shop do a thorough check. I wish my long roof had such low milage! Contact me if she wants to sell it.
 

·
Registered
Joined
·
39 Posts
wow that is super weird op. do you have any updates for us? is there any sound you remember in particular on the ride home you can tell us? any lights going off? when it was idle did you notice anything weird? definitely press the place you got it from for more info - and the quicker the better if you are this unsure. shame on them if they sold something they knew was not up to par.
 
1 - 7 of 7 Posts
Top