Taurus Car Club of America : Ford Taurus Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
my horn on my 2000 mercury sable dont work the fuses and relay it good but idk where the connectors to clean are nor the horn is please help
 

·
Registered
Joined
·
23,363 Posts
Iirc, down below and in back of driver headlight sit the high and low note horns? On 99s, they were located similarly, but on each side (driver and pass.).
 

·
Devoted Member
Joined
·
2,426 Posts
Iirc, down below and in back of driver headlight sit the high and low note horns? On 99s, they were located similarly, but on each side (driver and pass.).
There's one on each side on my '96 LX.
 

·
Registered
Joined
·
23,363 Posts
You might get lucky cleaning elec. conn., but often the only fix is to replace the horn(s) which are readily available at parts stores. Remember, you have a hi and lo note horn. You might check owners manual first for horn fuse and relay location and ensure they are good.
 

·
Registered
Joined
·
23,363 Posts
Turn steering wheel all the way to the right. Remove front half of plastic wheel well liner and jack up driver front of the car. Horn(s) should be visible in wheel well towards the front of the car. Unplug and unbolt.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #13 ·
I found the reason the wires were cut the is a green and a black in the black in the same group and two blacks in the same where does the two blacks go
 

·
Registered
Joined
·
23,363 Posts
Splice cut wires back together using butt connectors and/or elec. tape. Then simply slide on the spade connectors on each horn.
 
1 - 14 of 14 Posts
Top