Taurus Car Club of America : Ford Taurus Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
OK. Started off simply enough - just a Power Steering pump in my daughters 1995 3.8l AXOD xaxle SE. Well, the pump had a small leak but the big one was actually the steering gear. Both shaft seals gone. OK I can do this - right? Well after much pain I got a re-manufactured part from the local Auto Zone installed. Started it up, bled it, no leaks, so far so good. Only not good. Less than a block away it lost all fluid. After a suitable cooling off period (for me not the car) it seems that the re-manufactured steering gear is leaking (badly) around the main steering shaft - the part that protrudes into the cabin and connects directly to the steering wheel. When I tore it down sure enough there was a lot of fluid collected into both the cabin side boot and the engine compartment boot. My thought was a defective part. The two PS hoses that had to be attached at install were clearly not leaking, and as far as I could tell neither were any of the fittings of the various tubes routed around the exterior of the steering gear. when I looked at with more fluid added it is literally pouring out of the boot. OK. Bad part. Did it all again. Same exact result. What am I missing? Is this just a coincidence that two parts were both defective in the same way or am I missing something? This is a big project for me and I don't want to do a third time with the same result. What did I do or not do? I reinstalled the little blow off valve. Doesn't seem like it would be the issue even if it was left out or installed backwards (pretty sure I got it right).

PLEASE HELP!

thanks! :(
 
1 - 1 of 1 Posts
Top