Taurus Car Club of America : Ford Taurus Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
1,090 Posts
Discussion Starter · #1 ·
Well here it goes:

Recently, sometimes when I start up my 1995 Taurus LX with the 3.8L Essex it gives it a good try for a second or two and then just dies/stalls. I can keep it running when this happens if I notice it by giving it a bit more gas for a few seconds and then it will settle down into a rough idle when I let off.

I replaced the IAC valve a few months ago, and I recently found out that I have the California emissions system in it. (Even the guys at the dealership couldn't tell me that just by decoding the vin!) Both exhaust manifolds have been replaced, but the EGR is untouched.

Any ideas/opinions on what I should check/do to alleviate the stalling problem?
 

·
Premium Member
Joined
·
1,090 Posts
Discussion Starter · #2 ·
Bump, somebody has to have a clue. :(

I really don't want to drop it off at the stealership only to have them say "yeah, it's the EGR valve and here's your $100 diagnosis bill."
 

·
Registered
Joined
·
670 Posts
The usual culprits all out of the way like the fuel filter, air filter, plugs/wires?

Vac leaks sounds like it is if IAC is good.

How about giving the MAF a cleaning with MAF cleaner.
 

·
Premium Member
Joined
·
1,090 Posts
Discussion Starter · #4 ·
The plugs, wires, cap, and rotor were replaced in January. I haven't checked the fuel filter since it has only been 3 years since I replaced it.

I will check for vacuum leaks, look at the air filter, and clean both the MAF and throttle body with the appropriate cleaners when i take it into the shop tomorrow.
 

·
Premium Member
Joined
·
1,090 Posts
Discussion Starter · #5 ·
Replaced the fuel and air filters, and it seems that the air tube coming off of the air box was extremely loose. This may have caused most of the problem because it would have essentially been a vacuum leak.

Still need to clean the MAF sensor and the Throttle body.
 
1 - 5 of 5 Posts
Top