Taurus Car Club of America : Ford Taurus Forum banner

1 - 13 of 13 Posts

·
Premium Member
Joined
·
1,300 Posts
Discussion Starter #1
A while ago I read a detailed how-to post on cat converter replacement. I searched for "cat converter" and "catalytic converter" but was unable to locate the thread. If anyone remembers the post/thread, please help me out. I need to know what's involved in cat replacement. I just read a sticky that says difficulty of the job is 4 out of 5. I am willing to tackle it, for I can keep it in the garage for weeks. Thanks.
 

·
Premium Member
Joined
·
15,578 Posts
Is this for your 2005? If there's an issue with it, you should be able to get the cats replaced for free, under warranty. IIRC, manufacturers are required to replace cats that fail up until like 100K miles, for free, regardless of the OTHER portions of your warranty.

Also, how many miles can you have on a 2005? I would very seriously doubt that your cats have failed at this point.

JR
 

·
Super Moderator
Joined
·
7,869 Posts
I believe the federally mandated emissions warranty, which includes cats, is 8 years / 80,000 miles.
 

·
Premium Member
Joined
·
1,300 Posts
Discussion Starter #9
2005 90k miles. Out of warranty.
Code=P0430.
Bank 2 O2 sensor numbers flipping btwn 0.1 and 0.8, both up and downstream.
Bank 1 O2 sensor numbers flipping btwn 0.1 and 0.8 upstream, and steady 0.4~0.7 downstream. Could be bad downstream sensor.
There is no doubt cat bank 2 is bad. I need to find the cause of deterioration before replacing it.
If you come across the thread, please let me know.
Thanks.
 

·
Premium Member
Joined
·
1,016 Posts
2005 90k miles. Out of warranty.
Code=P0430.
Bank 2 O2 sensor numbers flipping btwn 0.1 and 0.8, both up and downstream.
Bank 1 O2 sensor numbers flipping btwn 0.1 and 0.8 upstream, and steady 0.4~0.7 downstream. Could be bad downstream sensor.
There is no doubt cat bank 2 is bad. I need to find the cause of deterioration before replacing it.
If you come across the thread, please let me know.
Thanks.
[/b]
Misfire.
 

·
Premium Member
Joined
·
1,300 Posts
Discussion Starter #13
My apology for bringing up this old thread. But I finally I located the thread, which I find much informative. Thanks for all replies.
http://www.taurusclub.com/forum/index.php?...c=25107&hl=

SHOZ:
As you suggested, I replaced O2 sensor, upstream only, hoping that it's sluggish response is "adding to" bad converter, throwing the code. It's been about 500 miles, and no code has returned yet. But it's too early to tell, for scanner still reports one INCOMPLETE element, whatever it may be.

MAVERICK:
I found one of the old spark plugs was fouled (black), distinctively different from others (brownish gray).
 
1 - 13 of 13 Posts
Top