Taurus Car Club of America : Ford Taurus Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
07 with no heat or air and I think this vacuum line is the culprit. I opened the hood to check stuff and found it just sitting there as the pic shows. Does anyone know where or what it's supposed to be plugged in to?

Thanks in advance.
 

Attachments

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Have not verified that yet, it's my sisters car (my old car) and when she got to the house she said it was just blowing out the same temp air as the outside. Thanks

That's the washer fluid line for the windshield sprayer. Have you verified that the blend door actuator doesn't move inside the car?
 

·
Super Moderator
Joined
·
7,699 Posts
BDA is a common failure. Fortunately the part is fairly cheap from the aftermarket (around $40), and replacing the BDA only takes about 20 minutes.
 

·
Registered
Joined
·
6,579 Posts
Had a problem with a Dorman brand actuator. It functioned properly for heat but cost me a lot of time troubleshooting an AC that was not performing as designed. It did not stroke to fully closed off heat which added 15 degrees to the AC outlet temp. A JY Motorcraft branded one cured the issue.
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
4 Participants
Automender12345
Taurus Car Club of America : Ford Taurus Forum
A forum community dedicated to the Ford Taurus and SHO models, Mercury Sable and Lincoln MKS. Join the discussions on EcoBoost, aftermarket performance, and more!
Full Forum Listing
Top