Taurus Car Club of America : Ford Taurus Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
You all were very helpful last time I had a problem. 96 Sable LS with 75.5K. Last week at highway speed the speedo started to fluctuate +/- 40 mph. After a few minutes of this the green O/D (overdrive) light on began to flash. The book says "maintenence required" with this light on. When I turn the car off and restart it, the O/D light goes away. It seems the speedo fluctuations begin at speeds above 50 or so. It would also seem to be getting worse where the speedo would do it's crazy thing and nothing else would happen. Now the O/D light is coming on more often. There is an ever-so-slight disruption in the drivetrain, like the computer is compensating for something, then it does ok albiet with O/D light. I have checked all the fuses but have not checked any of the connectors behind the dash. I'll do that next...

Has anybody had this before? I am at the point where I am not sure I want to put a large sum of money to fix it.

Thanks in advance,

Ray

P.S. The previous topic does not give me a warm fuzzy feeling...
 

·
Premium Member
Joined
·
1,234 Posts
The O/D light flashing means the PCM (computer) has detected a problem with the transmission. In my case, it was the torque convertor failing, but that's just an example. You'll need to get the code(s) read for more information.
 

·
Premium Member
Joined
·
2,458 Posts
Take it to AutoZone and have them scan your codes. That sounds like a TC problem to me, since it seems to only kick out the code when the TC should be locking up (while in 3rd gear).
 

·
Premium Member
Joined
·
1,234 Posts
Yes, it is fairly expensive because the transaxle will have to be removed. When mine failed, I went ahead and put in a new transaxle, rather than just put a new convertor in a 100K mile transaxle, so I don't have a repair cost for just the TC. I believe the quote for just that was on the order of $1000-1500. Someone eho has had this done will, no doubt, pop in with a recent price :D
 

·
Registered
Joined
·
151 Posts
i don't mean to take over this thread but since it's on the subject of tranny's. . . .
on the 91 and up tranny can you feel when the t/c lock's up, or tell by the rpm's, if so i think i may have a problem AGAIN
 

·
Premium Member
Joined
·
1,125 Posts
yes you should be able to feel it lock up and tell by the rpm's

what has the temp been in your neck of the forest?
 

·
Registered
Joined
·
151 Posts
well the last time i drove it , it's been about 75* and up.
i mean the check engin elight used to come on every day, then once i found the egr vac. leak. but once i found it, it come's every 3 day's.
my mom say's that when she's on here way home at night going about 45, she said she don't feel a thump.

oh man is the tranny going out?!
 

·
Premium Member
Joined
·
2,090 Posts
most likley the VSS is bad (vehicle speed sensor)

Cheap part (25$) and fairly easy fix

Brad

(have the codes read to make sure)
 

·
Registered
Joined
·
151 Posts
okay wiat . . . i remember one time i turn off the car and the speedo was still reading, so i thought cable, plus it does'nt read when you go back.

well i thought that if the speedo was bad, then it would'nt read and the tran's would'nt shift.

plus i would've thought it would act like my honda does.
when i speed up the speed-o-meter register 10-15mph and above.

so a bad vss?.
hmmm
 

·
Premium Member
Joined
·
2,090 Posts
vss will usually be intermittent before it completly fails, and theres no cable going to the speedo in a 96+. Like i said, have the codes pulled and it will tell you EXACTLY whats wrong.

Hard to tell without more info, but id wager 5 bucks on my guess.

Brad
 

·
Registered
Joined
·
5 Posts
Discussion Starter #12
I called AutoZone and they said the only codes they can only read codes when the "Check Engine" light is on. In my case only the green O/D light flashes after the speedo goes wacky. Do you still think it could be the VSS? Where is that located under the hood? I'm on the verge of trading it but if I can fix it I'd could sell it on my own instead.
 

·
Registered
Joined
·
258 Posts
Just take it to a ford dealer and they could read your tranny codes.Also when is the last time you changed your fluid?My friend was charged 50 bucks to pull his codes for the tranny at ford hope that helps.
 

·
Premium Member
Joined
·
2,458 Posts
Originally posted by rstuehmer@Aug 28 2004, 03:14 PM
I called AutoZone and they said the only codes they can only read codes when the "Check Engine" light is on.  In my case only the green O/D light flashes after the speedo goes wacky.  Do you still think it could be the VSS?  Where is that located under the hood?  I'm on the verge of trading it but if I can fix it I'd could sell it on my own instead.
They are lying. They told me the same thing, and I argued with the clerk for a while, and convinced him to try pulling the codes. Much to his dismay, I had 4 stored codes, even though I had no CEL/MIL OR O/D light.

I think it's most likely the VSS or something along those lines, if your speedo is going nuts.
 

·
Registered
Joined
·
151 Posts
it's normal on mine's, yea.
well after the rack was replaced, battery was disconnected, but yesterday, i had the air, on and the ecm seem to be on top of thing's, cause before the compressor would engage the idle would go up alittle, then dissengage the idle would go down.
but no check engine yet.
 
1 - 16 of 16 Posts
Top