Taurus Car Club of America : Ford Taurus Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Ok heres my problem, i hear a rattle from the time my car is started, to the time i turn it off, its coming from the front of the engine, around the alternator, water pump, front of the oil pan, waterpump , cat ect. also i get a check engine light after driving my car about 10minutes, sooner if the cars been ran and i crank it back up. its a 91 wagon w/ the 3.0, any suggestions? im stumped. Also the rattle really dont change w/ the rpms, it does increase some, but not much when the engines reved.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #2
also i might add once the chech engine light comes on, the engine seems to loose a lil bit of power, not a whole bunch but its noticeable :ph34r:
 

·
Registered
Joined
·
78 Posts
How long have you had the car and how long has it been like this ? You need to read the codes and post them before we can really help you. This is one possibility. One of your oxygen sensors have been malfunctioning for a while which caused your car to run rich, then fed too much fuel to the cat which in turn burnt it up and that is your rattle. Just one possibility out of quite a few.
 

·
Premium Member
Joined
·
2,277 Posts
Put your ear near the Cat. Converters.... One of them may be bad, hit them with a hammer and see if the ratteling goes away...

New York State replaces converters under 80k for free, check your local dealer and see if theres any warranties from the state on emissions system if this is the problem, if it is you could also weld in some catco cats....If this isnt the problem...well, hmmm......
 

·
Registered
Joined
·
135 Posts
I would check all the belts and pullies for rattle, and check engine lite
can sometimes be simple llike change gas cap or egr valve.
also i would unplug the MAF and clean the points w/windex
on a Q-tip, that can sometimes fix things. good luck.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
Ok, i pulled her up on some ramps, i recently inherited the car, my first one i might add, and i got close to the cat by the oil pan, i cant tell if its coming from the cat or the oil pan, but its definately in the lower part of the motor, could a water pump make those noises? also i notice, when im driving home and its cooler outside the SES light either doesnt come on for a VERY long time or it dont come on at all, but during the day when its hotter, it comes on quickly. And yes, my exhaust does always smell a lil rich, i got my car from my uncle, he got it @ 50k, it now has 161k, he said hes never replaced the cat or O2 sensors since hes had it.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
BTW the rattles not very loud, u can hear it outside the vehicle when idling, but when rolling u cant even tell its there, but when u get up under it, you can definately hear it loud and clear.
 

·
Premium Member
Joined
·
2,277 Posts
Sounds like the cats to me.... bring it to autozone or advance and have the computer scanned. I would say check the belt tensioner or water pump...or even a bad rod...but i dont think any of those would set off the SES light.
 

·
Registered
Joined
·
23 Posts
if your water pump is leaking, chances are real... real good, that some of the fins inside, or parts of the fins have broken off and are rattling around inside... not good seeing as the fins circulate the coolant. I would do this first, like right away... before you over heat it real bad and blow head gaskets or worse... without circulation, those radiators are so small, it will get hot and lose some power... and the temp light could be triggering your CEL...

good luck...
 
1 - 10 of 10 Posts
Top