Taurus Car Club of America : Ford Taurus Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I'm not seeing anything like this in any of the threads. Similar, but not the same. And if there is one please point me to it. Hope someone can point me in the right direction!

Last night I was sitting in a parking lot idling. Car in park. Something funky happened with the electrical. I'm not sure how to describe it. Sounded like something shorted or something. The theft light came on on the dash then went off. Whole thing lasted a couple seconds. Then I went on with my day. Nothing else happened. Car sat parked for a few hours, I went out and drove home later. No issues. Then this morning, I go out to the car, and the hazard lights are flashing and clicking and I don't have enough juice left to start the car. I replaced the battery with one I had in my truck. Had to drive to work with my hazards on and pull the battery cable when I got to work so I wouldn't run it down again.

I pulled relay 4 and they stayed on. I also pulled fuse 33 which my manual says is for the hazard flasher, and they still stayed on. Now, the manual in the car is for an '04 for some reason, but my car is an '03. So, I looked online, found an '03 owner's manual, and it said fuse 36, so I pulled it and they still stayed on.

A couple of the dash lights are out (I can't see how much gas I have at night!), but they haven't worked since I bought the car a month ago.

I read some forums on here and thought maybe it was the combination switch so I ran over and bought one and it still does the same thing.

I can hear a clicking like a relay or something somewhere under the dash, but I can't locate what it is.

Any ideas???? I don't have a good grasp of how the flasher circuits work.

Thanks in advance!
 

·
Registered
Joined
·
1 Posts
I'm not seeing anything like this in any of the threads. Similar, but not the same. And if there is one please point me to it. Hope someone can point me in the right direction!

Last night I was sitting in a parking lot idling. Car in park. Something funky happened with the electrical. I'm not sure how to describe it. Sounded like something shorted or something. The theft light came on on the dash then went off. Whole thing lasted a couple seconds. Then I went on with my day. Nothing else happened. Car sat parked for a few hours, I went out and drove home later. No issues. Then this morning, I go out to the car, and the hazard lights are flashing and clicking and I don't have enough juice left to start the car. I replaced the battery with one I had in my truck. Had to drive to work with my hazards on and pull the battery cable when I got to work so I wouldn't run it down again.

I pulled relay 4 and they stayed on. I also pulled fuse 33 which my manual says is for the hazard flasher, and they still stayed on. Now, the manual in the car is for an '04 for some reason, but my car is an '03. So, I looked online, found an '03 owner's manual, and it said fuse 36, so I pulled it and they still stayed on.

A couple of the dash lights are out (I can't see how much gas I have at night!), but they haven't worked since I bought the car a month ago.

I read some forums on here and thought maybe it was the combination switch so I ran over and bought one and it still does the same thing.

I can hear a clicking like a relay or something somewhere under the dash, but I can't locate what it is.

Any ideas???? I don't have a good grasp of how the flasher circuits work.

Thanks in advance!
Any answers ? Mine is doing this.......
 
1 - 3 of 3 Posts
Top