Taurus Car Club of America : Ford Taurus Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
I wanna know if anyone else has had this problem. I have a 99 taurus and my passenger side window only works when it wants to. when it works, it works perfect but sometimes it doesnt work at all. I think its a loose connection but I was wondering if some1 else knows exactly what it is.
 

·
Premium Member
Joined
·
15,578 Posts
I have had a similiar problem off and on for the past two years. When it is wet out, it will be very difficult to get the window down for the first inch or so. After that first inch, the window goes down perfectly smooth. It doesn't happen every time it's wet though. Sometimes the window will operate completely perfectly. It really makes no sense. I've had it looked at, and of course it didn't act up when my gf's dad was looking at it. It's definitely not the motor, the switch, or the connections, and it seems to be completely on track.

JR
 

·
Premium Member
Joined
·
122 Posts
That now happens to my driver side window. Right now its stuck down...it wont go back up. I checked the fuse and relay and popped off the door panel to make sure the plug was in.

All i got now is to check the switch and see if its messed up or something.

I thought it was the relay cuz whenever i press down the relay clicks...but i assume thats supposed to happen right?
 

·
Registered
Joined
·
1,963 Posts
My driver window is still doing this occasionally. Is there a fix to this problem?
 

·
Registered
Joined
·
1,963 Posts
Originally posted by Firespirit@Aug 29 2004, 02:46 PM
I had posted some information that I had found on the v8SHO site... just search on http://www.v8SHO.com/ and you'll find the answer...
Yeah, I saw that, but it didn't fix my problem.
 
G

·
The reason why it works when you bang on it:

Window motors are permanent magnet motors, with the fields glued to the outer casing. Sometimes, the glue will come loose, or enough crap will get in there to short the fields against the armature. When that happens, the motor won't work. Banging it frees up the crap, and makes everything hunky-dory again.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #11 ·
I got it fixed and it turned out it was the switch. Mine worked when i banged on it but it got so bad it stopped working. I replaced the switch and now it runs fine.
 
1 - 11 of 11 Posts
Top