Taurus Car Club of America : Ford Taurus Forum banner

1 - 7 of 7 Posts

·
Banned
Joined
·
509 Posts
Discussion Starter #1
You might know that I have the blue Gen3 Gauges in my car.. Well, I started noticing that when I was doing 70 according to the Speed-o, everyone was still passing me..

So I got my handy dandy GPS, and I tested the Speed-o, It seems that it is off my 10 MPH..


Is it possible to fix this? The needle doesnt rest on the little stopper thing, because after I closed it all up, I noticed it.. but it isnt sitting at 10 MPH..

What should I do?

Is there a secret to aligning them right?
 

·
Premium Member
Joined
·
15,922 Posts
Don't G3 gauges go upto 110 and G4 guages go upto 120? I guess you could find some wheels that will adjust the speedo. On my mechanical speedo, I adjust the speed by moving the needle up and down. I don't know how to fix it on the electronical speedos.
 

·
Premium Member
Joined
·
2,090 Posts
gen 3 vulcan = 110 mph
gen 3 duratec = 120 mph
gen 3 sho = 150 mph
gen 4 vulcan/duratec = 120 mph

EDIT: added sho
 

·
Banned
Joined
·
509 Posts
Discussion Starter #7
Originally posted by DeltarMN@Feb 8 2004, 10:15 PM
Pop the needle off take the GPS go out on a long strait highway some were and set your cruse controls at a speed lets say 50 (for example) you can tell your at 50 by the GPS. Then pop the needle back on with it pointing to 50 mph. This should work.

Edit: I've used this way of doing it on my gen 3 before and it works.
Yeah, but doesnt that seem a little dangerous? Like, you could loose controll or something..
 
1 - 7 of 7 Posts
Top