Taurus Car Club of America : Ford Taurus Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
461 Posts
Discussion Starter · #1 ·
1993 Ford Taurus LX 3.0 42k mi. The car has been averaging about 13 to 15 mpg in the city. I changed the fuel filter tuned the car up and tried using different grades of fuel.What is there left?
 

·
Premium Member
Joined
·
821 Posts
When was the last time you replaced your air filter? if it's been a while check/replace that next.

BTW, Welcome to the :tcca:
 

·
Registered
Joined
·
318 Posts
Plugs?
Clean the MAF?
Replace the Oxy sensors?
 

·
Registered
Joined
·
461 Posts
Discussion Starter · #4 ·
Thanx

The Air Filter was replaced about a month ago by my dealer when I took the car in for service.

I don't know if it is related but the Check Engine light has been coming on intermittently when the car goes over 35 and turns off when the car drops below 15 or the car comes to a stop.
 

·
Registered
Joined
·
16 Posts
It could be the O2 sensors throwing a code, but have the codes read so you're not replacing parts that are OK.

I just replaced my O2 sensors with the hope that my mileage will increase - getting 23mpg highway - used to get 26-27mpg. Also I never replaced them after the head gasket blew last year & contaminted them - no check engine light however.
 

·
Premium Member
Joined
·
569 Posts
I wish I would get a CEL :( Lilu's throwing ~15mpg ever since summer came along, down from 22 over winter. Stupid hot weather.

Check the CEL though, there's probably a stored code in the computer to help point you in the right direction.
 

·
Premium Member
Joined
·
821 Posts
You can go to autozone and have them read it for free. If you don't have an autozone check if any of your local parts stores will read them fro you or if they have a tool rental service where you can borrow a code scanner read it yourself in the parking lot then return it.
 

·
Registered
Joined
·
461 Posts
Discussion Starter · #9 ·
I went to Kragen (My local auto zone wont test it) the Kragen had a 5 day wait on the scan tool. I broke down and spent $30 on the scan tool. Ran the test and it gave me back a Code 181 System lean. Could this cause the poor mileage?
 
1 - 9 of 9 Posts
Top