Taurus Car Club of America : Ford Taurus Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone,

I'm having an issue trying to replace the bulb on my 2013 Taurus. I know a lot of people have had issues trying to access this bulb because the space is so cramped, but thankfully I could get at it. However, to my disappointment, I just could NOT get the bulb out of the housing and I don't know why. All the tutorials I've seen just show them pulling on the bulb and it coming out. Am I missing something? I've included a picture for reference, just in case. Please let me know if you need any more info. It's very frustrating! Thanks!
216278
 

·
Registered
Joined
·
56 Posts
It's probably a bit melted/stuck in there. I would rock it side to side to loosen it til it pulls out. Use a bit of dielectric grease after you get it out to prevent it from happening again. And yes, they are a PITA to get out of the housing!!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
It's probably a bit melted/stuck in there. I would rock it side to side to loosen it til it pulls out. Use a bit of dielectric grease after you get it out to prevent it from happening again. And yes, they are a PITA to get out of the housing!!
Thank you for the suggestion! I decided to use some more force and wiggle it like you suggested (I swear the bulb was going to break) but then it finally gave way! I put in the new one and shoved it back up the wheel well (ow). Many thanks!
 
1 - 3 of 3 Posts
Top