Taurus Car Club of America : Ford Taurus Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
Had a very good example of how this particular coil pack fails from heat over the years. The misfire may be intermittent or only when wet out. Either way this particular coil pack style which is used in the Taurus Windstar and 4.2L F150 all fail the same way. If you have a misfire you are fighting I urge you to take a closer look at the coil pack as shown for these common signs.

 

·
Registered
Joined
·
2,390 Posts
Thanks again great video.B) I post your video's for people who don't search frequently-_- Great format Keep em coming!! (please):)
 

·
Registered
Joined
·
226 Posts
Makuloco,

Your videos are great, very professional. Thanks.

Also - where are you located?
 

·
Administrator
Joined
·
15,109 Posts
Thank you for the post. Since there are few failures more common it has been copied to the Solutions to Common Problems forum
 

·
Super Moderator
Joined
·
8,109 Posts
Excellent video! Keep them coming, and thank you for your time and effort making them!
 

·
Registered
Joined
·
360 Posts
Thanks for the post
It reminded me to give my wires and coil a good look over
I've been chasing a long cold crank, and general lack of power and rough idle
Cleaned the coil pack and looked it over, whole things cracked to hell, and the front bank of plug wires are arcing to the valve cover.

You've done all of us Ford overs a real solid, Thanks for all the good advice.
 

·
Registered
Joined
·
2,446 Posts
Nicely done, very informative, gives meaning to the saying "a picture is worth a thousand words"!!!!
 

·
Registered
Joined
·
33 Posts
Watching the video made me want to check mine out and guess what? It has the same exact problem as the one in the video! Very helpful! Thank you!
 

·
Registered
Joined
·
1,987 Posts
Our Freestar has the same coil pack. It crapped out at about 135K miles. My wife was 200 miles away at the time. Trailered it home and replaced it. No cracks, though.
 

·
Registered
Joined
·
3,268 Posts
I changed mine with an aftermarket NAPA Echlin one for the time being. There were cracks all over the housing, and hairline cracks in the epoxy. At only 79,700 too. They're just a bad design.
 

·
Registered
Joined
·
22 Posts
just saw this.....awesome job with the video. I just did my own tune up and changed my coil pack out at 102,000 miles. Hopefully the new one lasts as long!
 

·
Registered
Joined
·
83 Posts
Thanks Brian, Your videos are awesome! I had no idea you were apart of the Taurus Forum as well! This gives you even more credibility in my eyes!! Love it!
 
1 - 16 of 16 Posts
Top