Taurus Car Club of America : Ford Taurus Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
430 Posts
Discussion Starter · #1 ·
Just wanted to give a report on my intermittant oil pressure light problem that I got alot of advice on. I was finally able to get back to my son's car. 99 DOHC had occasionally had a flickering oil pressure light at idle. Only did it once every 6 or 7 days. I also had let the oil go longer than I should have. I removed the passenger side cooling fan and the oil filter. I had a hard time getting the plug off the pressure switch, I actually broke it. Got another plug at the salvage yard and spliced it in. I used a 13/16 deep drive socket a swivel joint and about a 5 inch extension and managed to get the switch out. With my son turning a pressure guage from above and me guiding it with one hand from below we managed to get the guage installed. I bought a cheap filter and installed that. I also put in a can of seafoam. On start up had 70 psi, as it warmed up it dropped to a solid 35psi. This is with the old oil and a can of seafoam. Removed oil filter, drained oil, and replaced oil pressure switch with a new one and put in Motorcraft filter. I am confident that the oil pressure switch was the cause of my light. All appears good. Time will tell. Thanks for all the help.

Ed
 

·
Premium Member
Joined
·
17,415 Posts
I know you have been battling that issue for a long time (been following the threads). Glad to hear you got the light (hopefully fixed).
 
1 - 2 of 2 Posts
Top