Taurus Car Club of America : Ford Taurus Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
A while back someone posted a topic about how their theft light flashes after starting their car. A few other people posted that they had the same problem. One mentioned that there was a pattern to it and after reading that I realized that my blinking had a patern to it as well. Anyway, did anyone find out what this blinking is? Would it stop if I disconnected my battery to try and reset the computer? I only have 1000 miles left on my warranty so if I have to take it in, I gotta do it soon. Thanks
 
X

·
Guest
Joined
·
0 Posts
Does your car have any trouble starting up? This happened to my mom's van after ford did a repair and an ecu update. Apparently they ended up killing the battery, so my mom's car would have trouble starting and have the theft light flash. Took it to autozone for the free battery test, the battery was gone.
 

·
Registered
Joined
·
71 Posts
That was my post, it happened to me twice. Both times it was a dead and dying battery that caused it. No other obvious battery indications until it just quit. First time left me stranded. Second time I had the presence to get it tested. I never did get an answer to the reason it flashed a pattern. Mine flashed 1 then 6 (16). Let me know how you make out.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #4
How long was it flashing before it died? Because mine's been flashing for at least a couple months now. It doesn't do it every time I start it, but fairly often.

BTW, is there a battery that anyone would recommend if I do need to get one, or will any battery from AutoZone or PepBoys do?
 
X

·
Guest
Joined
·
0 Posts
My mom's van did it for a month. It failed to start one morning when it had been sitting for 3 days. I replaced the battery with the duralast gold from autozone.
 

·
Registered
Joined
·
71 Posts
The first time it happened a couple times a week then not for about three weeks. When it came back it was off and on for about a week, then dead.
The most recent time once or twice around end of Nov. Then in late Dec almost every start. In early Jan got it checked before it failed and it was toast.
I recommend not waiting for full failure, go now.
 
1 - 6 of 6 Posts
Top