Taurus Car Club of America : Ford Taurus Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
132 Posts
Discussion Starter #1
Yup!! you read it correctly!!! I have joined the SHO owners club!!
(and the multiple Taurus owners club too, I might add)

Heres the stats

White 1994 Taurus SHO
Grey 50 /50 interior
3.2L ATX
Fully loaded with power sunroof to boot.. Kinda (more later)

Has high milage but what the heck it was VERY inexpensive... lemme explain!

saw this SHO in the Auto Trader (ontario)

listed as White SHO with 240,000 $2500 as is in the Sep 17-23 Issue
listed as White SHO with 240,000 $1250 as is in the Sep 24-30 Issue

Talked to the owner, found out he had spent a fair bit of money keeping the sho up to snuff and finally got sick of it! (I KNOW its a high maintenace Car)
owed 581 Dollars to Canadian tire for all the work they HAD already done!
Told me if I gave him 600 I could have it! (I almost DIED)
I bought it =] basically paying 581 dollars for the repairs done (I actually picked it up at canadian tire) and 19 DOLLARS for the SHO!!

well, on to the bad, Canadian tire said the EGR Sensor wire had a fault in it...
and they said it means taking the upper intake off and tracing the wire....
Car turns over and everything says go but it doesnt... the code was the code 335 or whatever so they replaced the EGR and Sensor, didnt work, thats why they decided it was the wire, Ill find out tomorrow at my own mechanics =]

And.. for anyone reading this....

I need real bad

Sunroof Switch (i only really need the switch... the cover and stuff is there.. but ill buy the cover as well just to get the switch)
Front license Place Bracket thing
Rear bumper cover (any colour, im planning to paint anyways.)

Thanks!
 

·
Registered
Joined
·
132 Posts

·
Premium Member
Joined
·
5,758 Posts
Thats cool! Congrats!

Hows your Essex swap coming along?
 

·
Registered
Joined
·
132 Posts
Discussion Starter #7
as for the 3.8L swap...

removed the lower subframe, drop the whole thing out and shipped the taurus wagon body off...

Head gasket is fixed, hopefully i can get it back together in next week or 2.. then im prolly gunna have to put it on hold until i get the SHO liscensed/insured and cleaned up =]

thanks for askin =]
 

·
Registered
Joined
·
132 Posts
Discussion Starter #9
well yeah.. 19 dollars for a SHO in undriveable condition right now...

depending how tomorrow goes at the shop.. then ill decide if i got the deal of my lifetime.. or screwed!

getting a rather long (And somewhat EXPENSIVE list of things i want)

Front License Bracket (any idea where to get one?)
Hard Button ETAC
Sunroof Motor Switch (anyone know how i can TEST the sunrrof without a switch?)
Rear Bumper cover
Rust bubble free door window mouldings

Gah! SHo are nice to drive. but i wouldnt wanna live in one =]

Vulcan dependability all the way baby =] er.... :blink:
 

·
Premium Member
Joined
·
8,401 Posts
:cool_shades: Sounds like a hell of a deal!
 

·
Premium Member
Joined
·
1,930 Posts
http://www.shoforum.com
You'll find all the answers to your questions and then some.

And BTW, your "expensive" list really isn't that expensive IMO.

Front liscence bracket--cheap from someone parting
Hard buttoned EATC--most expensive on list I would think $100-120 or so on ebay
Sunroof switch--cheap from someone parting, or make you own like many others have
Rear bumper cover--someone parting, or local yard $70-100?
Rust bubble free window moldings--good luck is all I have to say :lol:

I also doubt you'd be screwed even if it doesn't drive. I'm sure you could make up at least $600 in parts, if not more.
 

·
Premium Member
Joined
·
6,077 Posts
Originally posted by Crispy28@Oct 5 2004, 12:59 AM
well yeah.. 19 dollars for a SHO in undriveable condition right now...

depending how tomorrow goes at the shop.. then ill decide if i got the deal of my lifetime.. or screwed!
No way man, golden 100%. Part that car out and you'll see that cash back in a heartbeat. Nice find!
 

·
Registered
Joined
·
132 Posts
Discussion Starter #13
Well... got some more info...


IT'S ALIVE!!!!!

Yep... you heard it.
Car is running as of 11:30 this morning...
after messing around with the EGR Sensor wires and running a temporary bypass the car started right up and ran purrrr-fect. (ALMOST)

Car wont engage in D at all... not even a hint of movement.. its like its still in neutral... however If you start in the lower gears and get going you can switch to D and it goes just fine... weird huh? new trans is not out of my reach... If thats all i need besides paint and small stuff im going to go right ahead and start pumping money into it =]

Gotta tell you guys honestly... DAMN... that thing is quick!
=]

Signed up at Shoforum as CrispySHO =]
 

·
Premium Member
Joined
·
1,930 Posts
Oh yeah, I forgot to say Congratulations!

I'm GreenStreak over there. The 97 & the 3.0 weren't really necessary (though mine is 3.0L)
BTW, those guys are really big on using search, so I would advise you to search before you ask any questions they think have simple answers.
 
1 - 14 of 14 Posts
Top