Taurus Car Club of America : Ford Taurus Forum banner

1 - 20 of 20 Posts

·
Premium Member
Joined
·
4,619 Posts
Discussion Starter #1
alright, before i take my car in to the dealership i want to ask a few questions. a couple weeks ago i put on my FSTB. it fit, but when i drove it was hitting the engine. there is absolutely no room behind the engine for it while driving. which might be due to the fact that their is a factory FSTB installed behind the engine. anyway, i tried many times, but it won't fit without hitting. ever since i drove the car with the bar on (one time) i have noticed like some kind of vacumn leak or something towards the back of the engine. with the hood up, when i barely press on the gas pedal, there is a big woosh of air noise, and than the engine revs. you can feel this while driving, there is a lag. now i'm thinking something got cracked when i drove around the block with the bar on. but, before i take it in, can someone confirm that the car ISN'T suppossed to be making that noise. open your hood, barely touch the gas and tell me if you hear a big woosh of air before the engine starts to rev. almost sounds like someone is blowing air out of a really big straw or something.

2nd question.. on the 2004 the MAF sensor is in the opening of the air box. which almost makes it inpossible to make a CAI. i put in a K&N panel filter from my old car, before i had the CAI. and the car drove worse. i'm thinking cause the sensor is way too close to the filter and the oil is getting on the sensor. so i changed it back to the paper filter and it was driving better. so.... yesterday i took off my air intake silencer. i just want to know if it'll be ok since the MAF sensor is almost right there where the hole is now. do you think it'll get wrecked? also, my brother said someone was selling a high performance paper filter now that was suppossed to be better than K&N, has anyone heard of it?
 

·
Premium Member
Joined
·
1,228 Posts
ok one q at a time.

1.) a vaccum leak will cause a slight miss or cei light to come on. you'd hear it at idle and underload. You may be hearing the secondaries opening on th tec which your not used to hearing

2.)the maf is ok just spray it with some compressed air in a can. or some electronics cleaner. i'm 75% sure the dealer won't even notice the maf being oiled they'll just replace it. The maf will be ok with out the silencer but if your that worried put it back in

3.)fram now selling a hypo filter called the airhog but it probley sucks ass
 

·
Premium Member
Joined
·
4,619 Posts
Discussion Starter #3
Originally posted by Tman@Jun 28 2004, 07:37 PM
ok one q at a time.

1.) a vaccum leak will cause a slight miss or cei light to come on. you'd hear it at idle and underload. You may be hearing the secondaries opening on th tec which your not used to hearing

2.)the maf is ok just spray it with some compressed air in a can. or some electronics cleaner. i'm 75% sure the dealer won't even notice the maf being oiled they'll just replace it. The maf will be ok with out the silencer but if your that worried put it back in

3.)fram now selling a hypo filter called the airhog but it probley sucks ass
well, when i press the gas it is like a slight miss while its making that noise. the secondaries open up right away? i'm talking when the car is in park and the hood is opened and i slowly hit the gas its making that noise and like its....i can't really explain it. but maybe thats all it is is the secondaries.

the MAF sensor, i'm not really worried about it, but i was just wondering if i should worry about it.

the airhog. i'll have to try it. the K&N just aint cuttin it in my car.

does anyone else with a 2004 have a K&N installed right now?? are you having any problems?
 

·
Registered
Joined
·
470 Posts
I thought 2000-present Duratec motors didn't have secondaries, only the 96-99 'tecs have em.
 

·
Registered
Joined
·
549 Posts
Originally posted by MaltaTaurus69@Jun 28 2004, 07:48 PM
I thought 2000-present Duratec motors didn't have secondaries, only the 96-99 'tecs have em.
you are correct sir.
 

·
Premium Member
Joined
·
1,228 Posts
just tell them you hear a hissing noise coming from the rear of the engine...sorta like a vaccum leak and the tech's will find it and fix it...TRUST ME. I seen some stupid explainations on problems at my work but yet the tech's always manage to fix it.
 

·
Registered
Joined
·
712 Posts
Yes, I hear a sucking noise when I give it a little gas. Every engine will. A vacuum leak would cause more/different/louder sucking noises, though. Is mine the same sucking sound that you hear? I couldn't say. I don't think that either of us could describe it here, good enough for the other to really know.

I could get a sound byte of mine, if you like. But you'll have to wait til tomorrow. Even then, it might be hard to judge, because the volume can be adjusted.
 

·
Registered
Joined
·
112 Posts
I'm going out on a limb here, but there isn't an air intake I know of in the back of the engine. I mean I hear a sucking noise form the engine on my gen 4, but that is because I removed the airbox and have a cone in the bay. So there shouldn't be a natural vacuum noise in the rear. I would bet on a loose vacuum hose.
 

·
Registered
Joined
·
712 Posts
Here is what mine sounds like: click

The sucking noise is hard to hear in the clip (crappy voice recorder), but you can hear it when I just crack the throttle.

The description you gave could fit the normal noises that you hear in mine, but it's hard to describe engine noises on the internet.

*edit

BTW, I held the voice recorder right next to the TB, at the back of the engine compartment.
 

·
Premium Member
Joined
·
4,619 Posts
Discussion Starter #15
Originally posted by Racer X@Jun 29 2004, 09:30 PM
*cough*DontmentiontheFSTB*cough* :unsure:
hey now!! i'm not that dumb!! :p

ecar ~ i couldn't play your clip, it wouldn't let me.

also, the noise isn't really a sucking noise, its more like air being pushed out of somewhere before the engine revs.. like tons of air is being pushed out of something. ahh.. wish i could record it. all i know, is the car drives different ever since that happened.

i got an appointment on Thursday morning. i just hope they don't notice the air intake silencer gone. you don't think that would void anything do ya? i'm sure it won't, but they might say thats causing the problem or something. i don't know.
 

·
Registered
Joined
·
712 Posts
I emailed it to you.
 

·
Registered
Joined
·
108 Posts
I'm not up on Gen 4 tech but don't they have plastic upper intake manifolds on the duratecs? Or was that Gen 3?

Anyway, is it possible that the upper intake hit the FSTB when the engine moved during accelration and maybe cracked it?

If not, don't mind me, kindly disregard and go back to your thread in progress. ;)
 

·
Premium Member
Joined
·
4,619 Posts
Discussion Starter #18
Originally posted by sandrew@Jun 30 2004, 05:48 PM
I'm not up on Gen 4 tech but don't they have plastic upper intake manifolds on the duratecs? Or was that Gen 3?

Anyway, is it possible that the upper intake hit the FSTB when the engine moved during accelration and maybe cracked it?

If not, don't mind me, kindly disregard and go back to your thread in progress. ;)
yeah its plastic on the gen 4's. and i was also thinking that it might of cracked when it hit the FSTB. i can't see where it cracked if it did, but that could possibly be the problem.
 

·
Premium Member
Joined
·
1,005 Posts
It sounds to me like your airbox isn't closed all the way. I have seen this on a few cars of mine before. If one of the bottom tabs isn't plugged in on the cover and both clips are not on it will leak and you will loose all kinds of power. I once ran across the street with my car with no air filter in it. It felt like a 4 cylinder. It could also be something else loose on the intake or throttle body.

Also, don't let anyone stand over your engine when you start it. Just incase the intake decides to explode.
 

·
Premium Member
Joined
·
4,619 Posts
Discussion Starter #20
its not the airbox. i made sure the thing was closed all the way when i put the paper filter back in. checked it again earlier and it was still closed. but how could that even matter when my air intake silencer is off? theres a huge hole on the entire side of the airbox with the silencer gone.
 
1 - 20 of 20 Posts
Top