Taurus Car Club of America : Ford Taurus Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
:huh:

After driving around town for about 30-40m minutes, I get this crazy smell from the engine. It's like something is burning like perhaps grease, oil, metal? I know I have a small oil leak around the oil filter but I don't want to get that fixed just yet.

Perhaps there's some blow-by or something like that but it smells like the engine is just way too hot.

I've changes the oil after 2500miles and flushed the coolant but I still get this strange smell that you might get after you'd really made that engine work. The trans fluid has been changed too but that did not help. It never had this smell when I got the car but I remember really making that engine work (stop & start from the lights) when I was late for an appointment. I could smell it then an it has not gone away.

Any ideas???

thanks!
 

·
Premium Member
Joined
·
305 Posts
Sometimes rubber or wires on a hot block make a burning smell also. I know its funny but some of the best wrenches around can diagnose various car problems from smell. There is a blind mechanic one town over who has a huge waiting list, he says he uses hearing and smell to diagnose problems. :blink:
 

·
Premium Member
Joined
·
821 Posts
I'll be curious to see what you find mikey since i have the same issue. Mine smells more like burning rubber. All my fluids are good (clean and full), there's no obvious smoke, it's not the breaks and it's not the tires and there is nothing leaking on the exhaust. It seems like it coming from the engine but can't find anything out of the ordinary. I honestly can't remember when it started but its noticeable in just my normal 15 min drive to work and more prevalent the harder i drive the car.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #9 ·
Wow.....sounds just like what I am experiencing. Have you ever had a mechanic look into that? Have you contactesd Ford perhaps? I just haven't had the time to leave the car at the Ford dealer....they might come up with some BIG $$$$$$$ repair.

Thanks!
 

·
Premium Member
Joined
·
821 Posts
Nope, i deal with the ford dealer in my town as infrequently as possible. I have found that they are trying to scam people more and more with unnecessary repairs. Plus i don't feel like paying the top dollar prices they have to diagnose it since there aren't any performance issue i can find relating to the issue. If there was a local mechanic i trusted i'd be up for seeing what he can find. I've been through so many mechanics and just haven't found one i can trust and get along with.
 

·
Premium Member
Joined
·
569 Posts
If you find that your car isn't gulping fluids, then maybe your brakes are smelly; if the pads are overheating, theres a good chance they could be smelly, or the fluid may be burning. Have you gotten your brakes serviced lately, or do you notice worse brake power after driving? (I mean, more than normal)


An AAA site lists these common smells:

Burning oil- Heavy, thick odor (often accompanied by blue or black smoke).
Electrical fire- Acrid odor like burned toast or burned plastic.
Engine coolant or antifreeze- A sweet, steamy odor (usually accompanied by steam).
Overheated brakes or clutch- Similar to burning rubber.
 

·
Premium Member
Joined
·
821 Posts
Yeah it's almost been 3k since my last oil change and even if there were some oil dripped on the exhaust (which i don't see anywhere) during that change i would think it would have burnt off by now.

Yeah i though it could be the breaks also but i checked and they were not the cause as i mentioned when in my first post to this thread. Transmission was flushed in March so i know it's not trans fluid (and yes they used mercon V) In fact the only fluids that haven't been replace in the car yet is the power steering and brake fluid and i'm not noticing any problems with either of them.

As far as my breaking system goes i replaced the pads and inspected it in April, no problems found.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #14 ·
Come to think of it, I have this grinding, vibrating sound/feel coming from the front discs. I had the brakes replaced (pads and rear rotors) about 20M miles ago. Seems there's something wrong up front. I just noticed that smell coming out of the AC vents when the engine is off and the AC was on so it sounds as though it's coming from the engine area. Maybe I should get down and smell the brakes up front when I am parked after a drive.

Knowledge is power as they say.....

Mikey
:D
 

·
Premium Member
Joined
·
821 Posts
Originally posted by mikey@Jun 30 2004, 09:48 PM
Maybe I should get down and smell the brakes up front when I am parked after a drive.
That was how i determinied the smell wasn't coming from my breaks ;)
 
1 - 15 of 15 Posts
Top