Taurus Car Club of America : Ford Taurus Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I purchased a 1996 Taurus as my daughters first car.It appeared to be in pretty good shape and had a new inspection sticker on it.Turns out the rocker panels under the plastic are GONE. Long story short I replaced the cam syncro and sensor now the front Engine mount is gone. The one that is closest to the front of the engine bay to the right if looking in from the passenger side. Would this be ANCHOR Part # 2789 from Rock Auto? Can I replace this by jacking the motor with a floor jack?

Also mystery ATF leak. While teaching parallel parking and repeated attempts forward and reverse and steering lock to lock there was a trail of atf on the ground? It was near dusk but I jacked the car up and a small pool of atf came from what looked like below the torque converter area? About the size of a half dollar? Next day i slid back the sheet metal cover to look up at the torque converter and it was dry? I checked the steering rack boots and didn't see any evidence of leaking?The oil pan is leaking pretty good but the fluid on the ground was red? I put newspaper under the car but so far no atf leaks? Any ideas?

Thanks in advance. Great forum.
JimG
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Ok~ Thanks for the quick reply. I think I will try to sell or trade the car in.It is not worth tearing out the tranny to fix.I don't think I will do the mount either.The subframe bolts are pretty rusty and I dont want to risk breaking any.
Can the car be driven untill I find a replacement? It's still not leaking and I put another 250 miles on it? Would the broken motor mount cause any harm?

Have a great day thanks.
Jim
 

·
Registered
Joined
·
1,235 Posts
As long as the tranny doesn't get too hot it will work fine. Keep an eye on the fluid level. I don't have any experience with broken mounts.
 
1 - 4 of 4 Posts
Top