Taurus Car Club of America : Ford Taurus Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Ok...been here before can't seem to solve this problem. I have a 97 Taurus with the 3.0 pushrod engine with 160K. The engine misfires, spits and sputters, lacks power. Checked the compression 150lbs on all 6. Changed the plugs (looked good) and wires,checked the egr, camshaft synchronizer, fuel pressure is 38 psi koeo 30 at idle 38 running down the road. No codes being set... changed the ect ...vacuum is 16.5 at idle and very steady holds 20 at 3,000 rpms.... rapid deceleration rises to 24, vacuum numbers show compression rings worn, but i would not think low enough to to make it miss like this?? Cleaned the maf, burns no oil. Don't know where to go from here. I heard these cars had problems with intake manifolds?? I am leaning on maf sensor, but just don't know. This is a second car and not used much...what am i missing here?:confused:
 

·
Registered
Joined
·
3,377 Posts
what codes are you getting for the misfire? i noticed you didnt mention coil pack in all this. there are issues with the composite manifold but you would get a lean code with it. when you did the compression test was the engine warm?
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #5 ·
no codes being set, the engine was slightly warm when i checked the compression. Coil pack looked good, no carbon tracking, leaking etc....well the coil pack is cheaper than a maf. The car was intermittent before, now it is running crappy all the time.
Thanks 4 the advice
 

·
Registered
Joined
·
3,377 Posts
a misfire should throw a code, cel flashing. while car is running and in park did you rev the engine and see if it is smooth through the power band?
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #7 ·
yes i did rev it... an obvious studdering and misfire esp falls apart @ 3,000rpms idle is rough most of the time too. Checked the dpfe sensor too... reference voltage was .76 not the .8-1.0 it should be; however it is .8 when engine is running. It feels like a maf, retarded timing, or ign coil...it is bad and i would expect a code, but none to date. I can pull a plug wire or o2 sensor and get one so the pcm is at least reading stuff
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #10 ·
There is a slight water leak at the timing cover on the firewall side..this would at least let me check the timing chain. Just wanted to get it running right first in case compression rings are shot though it did run reasonable on the earlier intermittent days. I also have a cheap induction timing light. I notice the light quits producing a signal at anything above 1200rpms...just thinking it is a cheap light, but i may try it on my wifes Mazda to see for sure.
 

·
Registered
Joined
·
3,377 Posts
a maf will cause those issues.. before replacing, look for a leak after maf to the tb. a leak will do the same thing. there is a way to test for a bad maf also.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #13 ·
OK Tested the coil pack and maf both passed. Went back to the basics and rechecked compression as it had been several months. My gauge was sticking badly bought another one 4 cylinders at 125 #3@60 #[email protected] Filled holes with oil jumped to 150. Good news i finally found it, bad news i need another engine...not sure if the car is worth it although tires are new, ball joints shocks and everything else is good.
 

·
Registered
Joined
·
10,939 Posts
Get a low-mile junkyard engine?
Local U-Pull engine = $205 including tax. According to the website.

I got DPFE, PS pump, alternator off a '03 DOHC with 44K miles. Engine was removed to get the transmission. Other stuff picked off the engine and it went to the outback pile of engines. Guess not many people care.

I also took cam and crank sensors, and belt tensioner and pulley. From inside I got blend door motor and blower with control. Two wheels and tires.

-chart-
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #18 ·
Jy engine is the way i probably will go. There is a junkyard about 1 mile from my house says he has 5 or 6 3.8L, but no 3.0 The guy is super cheap and easy to deal with... Not sure if i can swap the 3.0 for the 3.8 with out too much trouble. I have the ax4n tranny and u engine code. I am not real familiar with Fords as i have always had chevy or japanese stuff. I did some work for my brother in law and he gave me the car. I probably already dumped $1,500 in it. I use it in place of my 1 ton dmax when i don't need a truck.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #20 ·
I may pull the heads and mic the bores... if not too egg shaped or worn stick in a set of rings and rod bearings. I do know the oil was changed regularly....i just need something that will last 30 or 40K
 
1 - 20 of 20 Posts
Top