Taurus Car Club of America : Ford Taurus Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
93 bull 3,8L Multi electrical problems. I was driving my cat the other day when all of a sudden the following equipment quit working- daytime running lights, dashboard and trouble lights, rear window defogger, heater blower motor and turn signals. It is an intermittent problem because after a couple of minutes, they all start working again. Sometimes, there is a bit of a low voltage problem as the blower is going slower. I tried switching the rear windoiw defogger on and off whiile everything was working and it did not affect the blower speed. (blower speed will be affected by low voltage caused by bad connection) and I thought that the extra load would decrease blower speed. It didn't affect it. When everything went off, I tried the headlights and they work. Everything else works when the problem is occurring and when it isn't. I checked the schematic and the only point of commonality of all of these problems is the fuse box. Any brainstorms from any of you out there?
 

·
Premium Member
Joined
·
455 Posts
right off the top of my head it sounds like a high resistance ground problem,
i would check the resistance to ground and to the negative terminal of the battery with a good meter, i would imagine less than 1ohm
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top