Taurus Car Club of America : Ford Taurus Forum banner
1 - 20 of 27 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter · #1 ·
AZ gave me a code of "EGR insufficeint air flow" but i took
the egr off and blew it out and put it back on, it looked ok and
pretty new. NAPA says ot could be oxy air sensor or catlytic conv,
can't that part be tested? i don't want to buy egr if it won't fix.
is the egr ok for a junkyard part?
it's for my 99 Duratec, 75k miles, otherwise runs good.
anyone have this problem before?
thanks, dave
 

·
Registered
Joined
·
167 Posts
DPFE is usually at fault here but could also be a vacuum leak (is there any hissing from the engine?) or it could be clogged throttle body ports as was the case on my car.
 

·
Registered
Joined
·
135 Posts
Discussion Starter · #6 ·
thanks for the insights, there are no apparent hisses or vaccume
leaks, so i will look in the book for this DPFE part and hope it is not
too hard to get to.
hey silvapain, i really like those stripes, a fine looking ride.
thanks, Tauri Bro's dave
 

·
Premium Member
Joined
·
689 Posts
I bet it is the DPFE sensor. It was for my GL. Its a really easy replacement if you have a vulcan. Its a small silver box that sits on the pleanum. It has two vacuum hoses. You can't miss it.

Good Luck
Adam
 

·
Registered
Joined
·
109 Posts
Guys,

The DPFE.... is this the back pressure sensor? The silver rectangular box? The reason I'm wondering is I've got to think this deal fails very frequently on Vulcans. My previous car, a '96 Vulcan, got a check engine light and was running a little rough...... not rough..... uneven right at 40-45 mph. Took it to a guy who ran the computer code and told me it was the back pressure sensor and pointed to it. Said, "get it at Ford or I'll put it on." Went to Ford and got if for $59.36 (part # F4ZZ9J460B) ...... Anyway, the Ford parts guy says, "I've got 35 of those in inventory and we sell about 10 per day."

So 2 things come to mind..... if the friggin' part is failing like crazy then Ford's got a defective part. And they get to profit as a result.

And #2..... if it was know what parts are being sold at a rate of 10 per day.... it'd sure make it easier to diagnose the problems.
 

·
Registered
Joined
·
145 Posts
Sorry to jump in here but will it make the car run any better after replacing it? Mine is bad too(or so I think) and now I gotta shell out 80 bucks. Man I hope that this is it...
 

·
Registered
Joined
·
109 Posts
The only thing I noticed on mine other than the Check Engine or Service Engine Soon light coming on was a little uneven running between 40-45 mph. VERY minor. Not sure anyone would have noticed but me.

Before you pay $70 check around. There may be parts places for much less. And, hey take the thing off, blow some air through it, clean the contacts. Who knows, it may go a few thousand more miles. You can turn the dash light off by pulling the battery cable ground off for a few minutes.
 

·
Premium Member
Joined
·
3,449 Posts
Originally posted by hotwater@Sep 28 2004, 03:22 PM
Sorry to jump in here but will it make the car run any better after replacing it? Mine is bad too(or so I think) and now I gotta shell out 80 bucks. Man I hope that this is it...
If youve got less than 75K on your car the EGR should still be under warranty (If its at least a 2000). If I remember they extended the warranty on the EGR components specifically because of the problems they were having with them. I got a notice in the mail about it when the problem was first noted by ford.

-Damon
 

·
Premium Member
Joined
·
10,022 Posts
Originally posted by hotwater@Sep 28 2004, 02:22 PM
Sorry to jump in here but will it make the car run any better after replacing it? Mine is bad too(or so I think) and now I gotta shell out 80 bucks. Man I hope that this is it...
Not really. The EGR system is used to lower combustion temperatures and lower NOx emmisions. It's not a performance issue.

The only thing that might improve performance is if the EEC has had to retard timing to lower combustion temperatures to compensate for the EGR not functioning. Do you notice any sounds of detonation? If it's pinging, that would be a sign of the EGR not functioning properly.
 

·
Registered
Joined
·
145 Posts
duratecchie, I wanted to try that but getting any warrenty work done here in Germany is almost impossible. And I already shelled out 50 bucks for the EGR valve before I found this site and learned about the DPFE.

silvapain, the only thing that I have really noticed is the uneven running, almost like a surging that John in Charlotte mentioned.

John in Charlotte, $70 is probably gonna be the cheapest that I can find over here. American parts are pretty expensive here. Even though there is a Ford manufactuer here. Crazy eh. I am also limited as to who I can order from because a lot of places won't ship here from the states. Thanks to all for your help...
 

·
Premium Member
Joined
·
1,557 Posts
Originally posted by hotwater@Sep 29 2004, 12:51 AM
duratecchie, I wanted to try that but getting any warrenty work done here in Germany is almost impossible. And I already shelled out 50 bucks for the EGR valve before I found this site and learned about the DPFE.

silvapain, the only thing that I have really noticed is the uneven running, almost like a surging that John in Charlotte mentioned.

John in Charlotte, $70 is probably gonna be the cheapest that I can find over here. American parts are pretty expensive here. Even though there is a Ford manufactuer here. Crazy eh. I am also limited as to who I can order from because a lot of places won't ship here from the states. Thanks to all for your help...
Did you try cleaning the throttle body? On the contour I used to have, it had the 2.5 Duratec motor and that particular code meant that the passages in the throttle body were clogged and needed to be cleaned out. Lots of people just cleaned those out and those codes went away. On a few of them it did turn out to be the EGR or DPFE. At 70k it sounds like you're at the right mileage where those could be clogged up. Not really sure if it's as bad with the 3.0 Duratecs or if it's even the same.

Here's a link as to what it looked like on the 2.5:

http://www.contour.org/ubbthreads/showflat...b=5&o=7&fpart=1
 

·
Registered
Joined
·
145 Posts
Well, I did clean the throttle body oout. Also, it's a vulcan and I only have 50,000 miles. I only cleaned the throttle body from the opening though. I didn't pull it. Should I?
 

·
Registered
Joined
·
167 Posts
you need to pull the throttle body to get at teh EGR ports, they are behind a gasket
 

·
Registered
Joined
·
135 Posts
Discussion Starter · #18 ·
all the books i've seen just show the vulcan and not the duratec. so
i'll have to search a little more, ford quoted me $86 for DPFE here in ohio,
i'm gonna try to just clean it out and see what happens.
thanks
 

·
Registered
Joined
·
550 Posts
Have the dealer check to see if you've got Recall#02M01... this is a DPFE
replacement applicable to some Tauruses/Sables. I've done TONS of em' where I work!
 

·
Registered
Joined
·
167 Posts
DPFE is a sealed unit and I don't think it can be cleaned
 
1 - 20 of 27 Posts
Top