Taurus Car Club of America : Ford Taurus Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
111 Posts
Discussion Starter · #1 ·
i was wondering since this is a ford in this video was it just this model or can this be done to every model? an does all fords have this problem?
 

·
Registered
Joined
·
701 Posts
The way I understand this video is his throttle cable was stretched to the point where it wasn't fully opening the throttle body.
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #5 ·
yea thats what i was thinking but do the duratec motors have that same problem or has anyone really looked?
 

·
Registered
Joined
·
2,492 Posts
yea thats what i was thinking but do the duratec motors have that same problem or has anyone really looked?
High mileage vehicles CAN have that problem... I've personally NEVER seen it. fyi you would notice that much lack of throttle response. If you can't light pedal your vehicle.. there's your problem. No this isn't a Ford problem or a specific vehicle problem. This is a lack of proper mechanical maintenance problem.
 

·
Registered
Joined
·
1,770 Posts
yea thats what i was thinking but do the duratec motors have that same problem or has anyone really looked?
It's not difficult to look at, when you're cleaning the throttle body or changing the air filter. Unless your car has lost its throttle response, I wouldn't bother.
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #9 ·
o ok thanks an its just a thing i forgot to overlook but when i clean the filter next time ima check my throttle body out just to make sure.
 
1 - 9 of 9 Posts
Top