Taurus Car Club of America : Ford Taurus Forum banner
1 - 20 of 28 Posts

·
Premium Member
Joined
·
1,228 Posts
Discussion Starter · #1 ·
http://www.imagestation.com/picture/sraid122/p07edb4d2740cfbb23bbc01704784530c/f8315cce.jpg' alt='' width='450' height='337' class='attach' />[/url]

[url=http://www.imagestation.com/picture/sraid122/pd7880b02903e9477cc525dbf495d92a8/f8315ce1.jpg][img]http://www.imagestation.com/picture/sraid122/pd7880b02903e9477cc525dbf495d92a8/f8315ce1.jpg' alt='' width='450' height='337' class='attach' />[/url]

[url=http://www.imagestation.com/picture/sraid122/pe7ee14e5dd438e73607f18dc644b267c/f8315caf.jpg][img]http://www.imagestation.com/picture/sraid122/pe7ee14e5dd438e73607f18dc644b267c/f8315caf.jpg' alt='' width='450' height='337' class='attach' />[/url]

[url=http://www.imagestation.com/picture/sraid122/p00a9bb8b5d96291c56648e1283c5b482/f8315a84.jpg][img]http://www.imagestation.com/picture/sraid122/p00a9bb8b5d96291c56648e1283c5b482/f8315a84.jpg' alt='' width='450' height='337' class='attach' />[/url]

[url=http://www.imagestation.com/picture/sraid122/paca473de6be3d60488bf5cf57ef6e7d8/f8315a94.jpg][img]http://www.imagestation.com/picture/sraid122/paca473de6be3d60488bf5cf57ef6e7d8/f8315a94.jpg' alt='' width='450' height='337' class='attach' />[/url]

ok here's what happened. I was cruising along at about 70 when the car in front of me ran over a semi-truck tire retread and kick it up in the air at my sho. So i sverved to avoid hit it and the rear end of my sho got lose and i tried correcting it but to no avil. I spun twice doing 2-360's and then bumping the gaurdrail at about 10 mph. I was facing the opposite way in taffic. Thank god no one was hurt or hit by me. It was complete accident and i wasn't speed or doing anything wreckless. Just happened that my worn out rear struts couldn't had a move like that so i went for a ride, and my sho paid for it. I should have just ran the damn tire over. :angry:
 

·
Registered
Joined
·
478 Posts
pics dont work for me <_< .....sucks to hear about your car man....at least your all right....
 

·
Premium Member
Joined
·
1,228 Posts
Discussion Starter · #3 ·
thanks man...are they red x's?
 

·
Registered
Joined
·
478 Posts
blue squares with a white question mark in them........if that helps any......it could be that my computer just doesnt want to load them...... :angry:
 

·
Premium Member
Joined
·
17,415 Posts
Right click and say "show picture" or the equivalent. thats what made it work for me.
 

·
Registered
Joined
·
276 Posts
I've got red x's cause I'm using IE. Imagestation really doesn't like you does it Tman? I tried show picture but it doesn't work for me.
 

·
Premium Member
Joined
·
17,415 Posts
Dude...look up, i said above .
 

·
Registered
Joined
·
276 Posts
I know, I said that I tried that and it doesn't work. But now for some reason only the first picture works.
 

·
Premium Member
Joined
·
17,415 Posts
Hmm...well thats weird. Go SuperFord!
 

·
Premium Member
Joined
·
1,228 Posts
Discussion Starter · #11 ·
thanks. It's only a car and all the damage is fixable. I'm just glad i didn't hit the rail sooner or harder or even another car.
 

·
Premium Member
Joined
·
4,619 Posts
yea i saw his car the other day. it really sucks. but at least you are ok and didn't get hurt. and a big plus that you work at a dealership. ;) we can always pound some of it out like with my white car. :lol2: you know thats in the same exact spot as mine was. and yeah, i can't see any pics either. even right clicking them, they still won't show up. but its kewl. i already know what it looks like.
 

·
Premium Member
Joined
·
2,075 Posts
Sorry to hear about your SHO Greg, but it might have been worse, if you had run over the tread. Always think postitive, you saved yourself even more damage by reacting the way you did. The power of postitive thinking.

besides, those red X's on your car don't look too bad..... :lol2: pics no work for me either.
 

·
Premium Member
Joined
·
1,228 Posts
Discussion Starter · #16 ·
i'll upload them to superford toniught...that way everyone can see them so be patient and thanks T-ROPER(see i got it right...hehe) I know it could have been alot worse especially if i hit another car and i ended up in the hospital
 

·
Registered
Joined
·
352 Posts
Sucks Bro,good luck with fixes. Glad your O.K.

By the way..........

:ttiwwop:
Actually the only pic I couldnt get is the first one. Damage doesnt look all that bad.Unless of course the first pic is the killer. :(
 

·
Premium Member
Joined
·
5,111 Posts
Glad you didn't get hurt or hurt anyone. But get the suspension fixed while you're at it. The suspension in my SHO is far from pristine, and the tires leave much to be desired, and I can handle an emergency switch safely at a much higher speed before things become a problem. If you're ever in a situation like that again, chances are that you may not be as lucky as you were this time, and may hurt yorurself or someone else. Safety doesn't just end with your brakes and tires...
 

·
Premium Member
Joined
·
1,228 Posts
Discussion Starter · #19 ·
i agree but my problem was it got a wee bit loose and my over correction caused me to spin. I kinda freaked out but i was able to control the car and keep in in the fast lane and shoulder. I have the struts just waiting for the springs to come in. I got a project for this weekend WOOT!
 

·
Premium Member
Joined
·
821 Posts
Sorry to hear about the car Greg, but glad to hear you made it out of that all right.
 
1 - 20 of 28 Posts
Top