Taurus Car Club of America : Ford Taurus Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I just bought my mom's 02 mercury sable and I realized that her CEL does not work at all... I can pull codes but the light never turns on. Is there any way to replace this bulb? Thanks.

Chris
 

·
Registered
Joined
·
23,581 Posts
Remove the instument cluster following instructions found in the topic finder feature at the top of this page. Iirc, it takes a #37 bulb. Until then, scan for codes periodically.
 

·
Super Moderator
Joined
·
8,732 Posts
2 most common reasons CEL doesnt work: 1) it was on for so long the bulb burned out. 2) CEL was on and PO removed the bulb so any prospective buyer would think it wasnt on, increasing the value of the car. Happens more than you would think.... lots of dishonest people out there.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Ha! The bulb should be burned out because I remember pulling codes off of it a few years ago. I will get the build replaced soon then. The women in my family tend not to worry about their cars. So I am hoping the low oil pressure light just needs the sender replaced... Here to crossing fingers...
 

·
Super Moderator
Joined
·
8,732 Posts
Oil light: check the million threads here concerning the CKP (cam position sensor) and the syncro shaft.

I missed the part about buying the car from mom :)
 

·
Registered
Joined
·
955 Posts
Thanks jeff. I was going to start digging through all of that soon. Thanks again

Just thought I would point you to the thread that I started and am pretty much done with. It talks to the Oil Pressure light (flickering anyways). I just did this change out on the Oil Pressure Switch (recommend renting/buying oil pressure gauge and putting on before swapping sensor) and the Cam Synchro and Sensor.

Hit me up if you need any help with those things. It's fresh in my mind.


Thread: http://www.taurusclub.com/forum/82-maintenance-repair/161622-flickering-oil-light-video-linked.html
 

·
Registered
Joined
·
23,581 Posts
Might be time to remove oil sender and install oil pressure gauge to see whats going on. ..... And then possibly drop exhaust and oil pan for a bearing(s) look-see. Maybe sender or oil pump?
 

·
Registered
Joined
·
23,581 Posts
Okacookie, for a good how-to tutorial for r&ring the oil pressure sender switch on a tec, click on Forums at the top of this page, then scroll down and click on Maintenance and Repair and go to page#773. Scroll down to: Finally Found My Oil Leak by maceslin (3-14-05).
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #13 ·
Awesome... I will just hope it's the sender... It doesn't happen all the time, but it was fairly common in the summer. My mom said "oh yeah that's been going for a while..."
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #17 ·
There is no knocking or chatter that I have noticed... My wife is the one driving it and says there is just a squeal once in a while. I am driving her old ford probe that snapped the timing belt, and that was a blast to fix.
 
1 - 18 of 18 Posts
Top