Taurus Car Club of America : Ford Taurus Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
437 Posts
Discussion Starter · #1 ·
Hi all, I don't think there is a single post anywhere in TCCA regarding these cam/belt driven waterpumps on 2001-plus duratecs? Are they incredibly reliable, because nobody ever posted any problems? Never heard of anyone replacing the belt or pump or any complaints . They are invincible? Just very curious about them. Are they good for a million miles?
 

·
Premium Member
Joined
·
17,415 Posts
I think I read of one guy replacing one in the past because his car was at 156K or something, but that's it...no one else.
 

·
Registered
Joined
·
437 Posts
Discussion Starter · #3 ·
Thanks Bull Geek, These waterpumps must be pretty good. My '01 SEL must be the first year to have the camshaft driven waterpump. It's actually the most accessible thing under the hood, on top of the motor! My curiosity is about nobody had problems with them. Maybe it's partly to do with everything being aluminum (duratec) . My cooling system is clean.
 

·
Registered
Joined
·
27 Posts
Hello Toronut,

I have 101K and was wondering the same about the pump. The belt still looks good. I also have not heard of anyone replacing it. It would be nice to know what the average life expectancy is on those pumps. I did go on an extended trip so I bought a spare belt which I've kept in the trunk, just in case. The belt tensioner is pretty small so it looks like the belt can be swapped out pretty easily.

Regards
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top