Taurus Car Club of America : Ford Taurus Forum banner

Status
Not open for further replies.
1 - 19 of 19 Posts

·
Registered
Joined
·
953 Posts
Discussion Starter #1
A HUGE thank you goes out to Bull Geek on this one! All I had to do was Clean the INSIDE connectors.

If you are having issues with EITHER the Cruise Control On/Off or the +/-/Resume CC buttons try this simple procedure first.

1) Use a small flat head screw driver and insert between the outer black plastic and the soft p-leather of the steering wheel. Pry outwards and remove the entire Black assembly from steering wheel.

2) Disconnect the 3/4 pin connector from the back of the assembly. Note: There are 3 wires going into the steering wheel.

3) Use a Torx T-9 or T-7 to remove the 3 Torx screws in the back. It should not take many turns to get these out.

4) Disassemble and using Isopropyl Rubbing Alcohol clean all Gold connectors with a Q-Tip.

5) Assemble in the reverse order.

If anyone has ever taken apart a video game controller (NES, SNES, N64, PSone, PS2, XBox, etc) the same principles adhere to this. There are essentially 3 pieces. The Black plastic, a rubber middle piece (used to pop the plastic back out), and a simple circuit board.

The connectors inside the indents of the rubber will collect dust/grime. This will transfer to the circuit board. When these connections are not good, intermittent or complete failure to work will result.

Remember to use Rubbing alcohol because it will not harm the electronics of the board. DO NOT USE WATER!

$2 worth of tools and $2 worth of Rubbing alcohol now my Cruise Control works just like it did out of the factory!
 

·
Premium Member
Joined
·
17,415 Posts
Topic moved. Good post :thumb:
 

·
Registered
Joined
·
32 Posts
My cruise control light will flash on and off real quick if I press the + or - button while driving. It never engages but simply blinks the light on the dash. Is this a sign of a cleaning, and how is that done on a 2000 model steering wheel? Also, my auto (down) feature for the driver's window does not work (the window goes up in down just fine otherwise). With this and the cruise control not working, could this be a fuse problem or wiring?
 

·
Premium Member
Joined
·
15,922 Posts
My cruise control light will flash on and off real quick if I press the + or - button while driving. It never engages but simply blinks the light on the dash. Is this a sign of a cleaning, and how is that done on a 2000 model steering wheel? Also, my auto (down) feature for the driver's window does not work (the window goes up in down just fine otherwise). With this and the cruise control not working, could this be a fuse problem or wiring?
[/b]
For the auto-down feature, you're sure you're pressing the button all the way down? The older cars is a press and release quickly for auto-down, but for the newer cars the button needs to be pressed down past regular down for auto-down.

If that is not the case for you, then there is a relay inside the driver's door that controls auto-down and it is independent of the cruise control.

For the cruise control, you have to press ON to activate it first (it turns off if you go below 35 MPH or turn off the engine) before pressing + or -. If that's not the case, then check the brake on/off switch on the brake pedal and make sure that switch working correctly (brake lights usually don't work if it's bad).
 

·
Premium Member
Joined
·
7,048 Posts
The cruise light will do as you described if the module can't pull the cable for some reason. I had one that built up enough rust, it locked up. Took the front panel off and gave it a good lube.
 

·
Premium Member
Joined
·
7,048 Posts
Thanks for the tips. Where is this module, so that I may give it a good lube as well? [/b]
Driver's side strut tower next to the master cylinder.
 

·
Registered
Joined
·
953 Posts
Discussion Starter #8
<div class='quotemain'>
My cruise control light will flash on and off real quick if I press the + or - button while driving. It never engages but simply blinks the light on the dash. Is this a sign of a cleaning, and how is that done on a 2000 model steering wheel? Also, my auto (down) feature for the driver's window does not work (the window goes up in down just fine otherwise). With this and the cruise control not working, could this be a fuse problem or wiring?
[/b]
For the auto-down feature, you're sure you're pressing the button all the way down? The older cars is a press and release quickly for auto-down, but for the newer cars the button needs to be pressed down past regular down for auto-down.

If that is not the case for you, then there is a relay inside the driver's door that controls auto-down and it is independent of the cruise control.

For the cruise control, you have to press ON to activate it first (it turns off if you go below 35 MPH or turn off the engine) before pressing + or -. If that's not the case, then check the brake on/off switch on the brake pedal and make sure that switch working correctly (brake lights usually don't work if it's bad).
[/b][/quote]


I do not believe that the cruise control turns off if you go below 35mph... I know that the cruise control will NOT activate if you are below 25mph. 25 seems to be the cut off.

I have never seen the Cruise Control light 'blink' when I press + or -. It is not that hard to take the black piece out and try cleaning the connectors. Follow the steps above to the 't' and you will be just fine. If that does not solve the issue, I would start tracing fuses.

Do you notice the MPH drop by (roughly) 1 mph (or increase 1 mph) when you hit the - (or +) buttons?

If you hold the - button down, does you speed slow down (at a coasting rate) until you let go of it? Does the light STAY off while you hold the button down?
 

·
Registered
Joined
·
32 Posts
[/quote]
I have never seen the Cruise Control light 'blink' when I press + or -. It is not that hard to take the black piece out and try cleaning the connectors. Follow the steps above to the 't' and you will be just fine. If that does not solve the issue, I would start tracing fuses.

Do you notice the MPH drop by (roughly) 1 mph (or increase 1 mph) when you hit the - (or +) buttons?

If you hold the - button down, does you speed slow down (at a coasting rate) until you let go of it? Does the light STAY off while you hold the button down?
[/quote]

No change in speed if I hit the - or + buttons. The speed does slow down if I hold coast but at a steady rate and presumably all the way to 0 if I let it. The 'cruise' light does not stay on if I hold the buttons down. Sadly I think the instructions to clean the contacts will not help with my 00 steering wheel but I will try finding the module and lubing the cable.
 

·
Registered
Joined
·
1 Posts
I have had similar issue with cruise control on my 2000 SEL. I am almost certain that it is the "plunger" type switch that disengages the cruise when the brake pedal is depressed (it works off of the arm of the brake pedal). There is a separate switch from the brake light. I have been able to get it to work for a period of time by simply wiggling the switch. After a while I would again get the "flickering-light" syndrome and I would have to repeat.

Now that my son is driving the car to college (car now has 146,000 miles), we can't get this to work anymore. I just ordered a new switch to see if that fixes the problem -- part number SW5955. It was only $16.00 on Amazon -- if this works, I wish I would have done this 60,000 miles ago!!

Regarding the push button contacts on the steering wheel -- have not seen a problem with those yet. However, what I do have is a similar issue with the keypad on the outside for keyless entry. I am wondering if I could do the alcohol trick to this -- it works sometimes, but seems to get bad contact. Does anyone know how to remove and reach these contacts for cleaning?
 

·
Registered
Joined
·
83 Posts
My sincere apologies for resurrecting an ancient thread. I would like to ask the OP what the original problem was. My cruise light does not turn on, nor does the cruise engage. I have replaced the fuse for the Speed Control and also removed the cable for the cruise module under the hood and next to the strut tower. The problem remains. If you can possibly describe the original issue before I go ahead and remove the switch I would be very grateful. Thank you.
 

·
Registered
Joined
·
1 Posts
need help, got a 1990 ford taurus 3.8, i made a long trip for vacation, used cruise all the way, when i got off of the interstate where i needed to be i went to get gas and noticed the cruise was not dis-ingaging. it is still doing it and i got back home on friday morning....need to figure this out soon, also starting this morning it stopped shifting, would that have something to do with the cruise sticking? how do i dis-ingage it..thank you
 

·
Registered
Joined
·
437 Posts
My 2001 cruise control won't turn off at the steering wheel ?. The brake will turn it off. Is this a problem with the clockspring or button switch?
 

·
Registered
Joined
·
198 Posts
can someone put pictures on here on how to do this i dont want to screw something up.:worthlesswithoutpicto some
 

·
Banned
Joined
·
323 Posts
need help, got a 1990 ford taurus 3.8, i made a long trip for vacation, used cruise all the way, when i got off of the interstate where i needed to be i went to get gas and noticed the cruise was not dis-ingaging. it is still doing it and i got back home on friday morning....need to figure this out soon, also starting this morning it stopped shifting, would that have something to do with the cruise sticking? how do i dis-ingage it..thank you
Might be the brake light switch. Step on the brakes, see if the brake lights come on. This switch controls the brake lights, turns off the cruise control, and unlocks the transmission so you can shift out of park.
 

·
Registered
Joined
·
25 Posts
My cruise Off and Resume buttons were not working. After reading this guide I thought I would give a try. They now both work great. Thanks!
 

·
Registered
Joined
·
1 Posts
I have a 2003 Mercury Sable which is having some interesting cruise control issues. First off, the light doesn't come on, but it engages. No computer codes on a malfunction. Second, it doesn't stay a constant speed. If I set it for 75mph it can go from 70mph to 85mph. This could get me into some trouble. Any ideas? All of the buttons seem to work without issue.
 
1 - 19 of 19 Posts
Status
Not open for further replies.
Top