Taurus Car Club of America : Ford Taurus Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
Hi, just wanted to know if for anyone else the coolent disappears. I don't think it is leakin out of the system since I don't see any drip marks at all. But sadly I think it might be goin into the engine. sighh I know this uses that screwed up new coolent. Gold colored crap. Don't know why they even switiched it. New stuff is more corrosive I have been told.
 

·
Premium Member
Joined
·
2,492 Posts
I've heard the red coolant is more corrosive then the green, but I have no idea if thats a fact...
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #4 ·
no the exhaust looks clean. But I never see any wet spots on or around the enigine or on the floor but it has to be going somewhere. The guy that runs the shop where I go told me about the gold being bad. That gold color stuff is what was in the car when I bought it, but it says in the book to use the green color stuff (very last page of manual). When I bought coolent to put in the car it matches the specs from ford but it gold. Which is the right stuff to put in.
 

·
Registered
Joined
·
397 Posts
If it is a slow depletion, it could be coming out somewhere around the water pump.

it will not be something that you can see dripping under your car. the leak may be just enough to be losing it. Really investigate around the water pump.

If the pump looks clean all the way around, then check elsewhere.

Mind you, the pump is kinda big where it mounts to the engine and checking all the way around is kind of a pain.

IF there is a dirty spot on the pump, clean it well and keep an eye on it for dirt or leakage over time.

Taurus pumps are known to leak

As far as the gold crap? They recommend using it in some GM vehicles, but I don't know about Fords.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top