Taurus Car Club of America : Ford Taurus Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
695 Posts
Discussion Starter #1
I picked up a cheap coil-on-plug unit from a Duratec (2000 was the only year they had them right?) which I plan on using in my SHO. The coil itself is a bit different from the V8 coils. It only has one mounting hole and is quite a bit longer (the plug boot).

Does anyone know why Ford went away from the COP design?
Are these things as reliable as the V8 coils (or as unreliable) ??
Anybody know what price the dealer charges on these?

I'm hoping they might be cheaper.
 
G

·
Ian, I haven't seen first hand, but I've heard that Ford went back to COP for the '04-'05 model year Duratecs. This may make them a cheaper alternative if they work correctly on a V8.

To my knowledge, the Duratecs don't have the same issues as the V8 regarding the coils. My guess is because the engine area is less cramped, resulting in less heat to damage the coils.

I don't have an answer to why they stopped using them for a few years.


Autozone lists a C1312 Wells unit for $45.99 USD. They also listed another number for more money, but it says the 1312 will work as well.

Hope this helps a little!
 

·
Registered
Joined
·
695 Posts
Discussion Starter #3
Thanks for the info Bob. I'll look into those coils.
 
G

·
It would be nice if it worked out, especially if the coils are more durable than the stock V8's. I know this goes without saying, but let us know how you make out!
 

·
Premium Member
Joined
·
14,126 Posts
Sure would be nice. Be sure the plug well is sealed good and that the plug wiring is the same.
 

·
Premium Member
Joined
·
3,449 Posts
Originally posted by godspunk32@Oct 3 2004, 11:10 PM
I'm sorry to sound ignorant, but what is the problem with the V8 coil-on-plug units?

JR
The SHO coil on plug units had a nasty problem of failing, more specifically the rear bank. The rear bank plugs were between the engine and the firewall, and because it was a V8 there wasnt much room for air to get in there.

Because there was so much heat build up there and not enough airflow, the rear coils had a habit of failing. With the duratec, its a smaller engine, and theres more room for airflow up in there, so AFAIK there have been no problems with coils going bad on any gen4 tecs.

Peace out
-Damon
 

·
Premium Member
Joined
·
500 Posts
Originally posted by Bob Gervais@Oct 3 2004, 07:29 PM
Ian, I haven't seen first hand, but I've heard that Ford went back to COP for the '04-'05 model year Duratecs.
Confirmed.
 

·
Premium Member
Joined
·
2,458 Posts
Originally posted by duratecchie+Oct 4 2004, 12:39 AM--><table border='0' align='center' width='95%' cellpadding='3' cellspacing='1'><tr><td>QUOTE (duratecchie @ Oct 4 2004, 12:39 AM)</td></tr><tr><td id='QUOTE'><!--QuoteBegin-godspunk32@Oct 3 2004, 11:10 PM
I'm sorry to sound ignorant, but what is the problem with the V8 coil-on-plug units?

JR
The SHO coil on plug units had a nasty problem of failing, more specifically the rear bank. The rear bank plugs were between the engine and the firewall, and because it was a V8 there wasnt much room for air to get in there.

Because there was so much heat build up there and not enough airflow, the rear coils had a habit of failing. With the duratec, its a smaller engine, and theres more room for airflow up in there, so AFAIK there have been no problems with coils going bad on any gen4 tecs.

Peace out
-Damon[/b][/quote]
:withstupid:
And the kicker is that a failing coil will usually give unusual symptoms in addition to a very slight misfire at idle, a "dip" in the accelleration curve, or stalling after high-rpm use, but it is often several thousand miles later that the CEL is finally triggered and the coil completely quits. The intermittant failure of the coil is often hard to diagnose and it is sometimes hard to pinpoint which coil is the bad one. And it seems to send a pile of RF or other electrical "noise" back to the PCM, which creates problems in other areas. For example, the car may stall out and the diagnostic code may read "random cylinder misfire" even though there is only one bad coil.

It was for this reason that I replaced all four of the coils on the back bank when I got the cams welded. It cost me an extra $300 in parts, but I knew I had at least one coil that was starting to fail, and the others probably would have given me trouble later on.
 

·
Registered
Joined
·
549 Posts
Our 2000 duratec has had problems with the coils.
 
1 - 13 of 13 Posts
Top