Taurus Car Club of America : Ford Taurus Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
99 taurus, 107K miles, Service Engine Soon lights. Checked the code at autozone. Anyone can help me? Thanks.
 
B

·
Guest
Joined
·
0 Posts
Most likely it's the DPFE sensor, which is located on the upper intake manifold. There's two rubber lines going to it from the EGR valve tube. It's actually a quite common failure.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thank you very much. I searched autozone for the sensor. But I can't find it. Where can I got it. And how much will it cost?
 
B

·
Guest
Joined
·
0 Posts
Sorry about that, evidently they call it an EGR pressure sensor in the brand they carry. Here's a link, it's for a Vulcan, but the Duratec should be the same one.

Autozone
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
another question. Do I need to clear the error code after replace the sensor? Or it will disapear automatically after the sensor replacement? And if I do need to clear it, How to do it?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
I didn't change the sensor because I am busy this week. But the light is off taday. The light is on before I start engine. So the bulb is good. Any suggestions?
 
B

·
Guest
Joined
·
0 Posts
Originally posted by smileboy@Apr 16 2004, 01:06 PM
I didn't change the sensor because I am busy this week. But the light is off taday. The light is on before I start engine. So the bulb is good. Any suggestions?
Nothing, other than just driving the car and checking the codes if the light comes on.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #11
The light comes back today. I had ordered a new dpfe sensor. Let us see what happened after i replace it. Thanks
 
1 - 11 of 11 Posts
Top