Taurus Car Club of America : Ford Taurus Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello.. I am from Poland. I have taurus 2013 police sedan. Everything works just climate control doesn't work. It does not respond to any button but the lights change. Outside temperature sensor dont work. . Maybe someone knows what might be wrong. Thanks and sorry for my English
 

·
Registered
Joined
·
29 Posts
Tell us more about what you mean by not working. What's not working
Fan
Is the fan running / working?
When the unit is powered on (lights are on, and you turn the fan knob up - does the fan speed increase?
Temperature
With the car warm - if you turn the temperature knob up or down, does the temperature of the air coming into the car change.?
Recirc
If you press the recirc button on do you hear a "noise" from under the right hand side of the dash. Press it off, hear the same noise again?
Mode
You say you press buttons and the lights change. Do you mean that regardless of which buttons are on, air always comes out of the same place? (Usually floor or defrost).
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Nic nie wieje, tylko przyciski są podświetlone. Temperatura zewnętrzna nadal wynosi 190f
 

·
Registered
Joined
·
150 Posts
Probably your HVAC control module. Just have to pull the sync screen and it sits behind there. Not a bad job.. if it were me, I’d buy a low mileage used one from ebay or a salvage yard and replace it.


Sent from my iPhone using Tapatalk
 
1 - 5 of 5 Posts
Top