Taurus Car Club of America : Ford Taurus Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hi!
Recently I noticed something strange with my car. Say I'm going 60 mph, the tach is about 2000 rpm, and if I try to accelerate slightly I feel vibration but the speed stays the same. First time it happened I didn't know what was going on so I let go off the gas and then depressed it harder. The rpm jumped to 3000-3500 and the car started to accelerate but it felt sluggish. So I did it a few times with even harder acceleration and eventually the check engine light started blinking. So I slowed down and the light stopped blinking but it stayed on. I had the code read and it was P0306, cylinder 6 misfire. So under the hood I go. Checked the spark plug: looks good (car now has 67k miles and spark plugs were replaced at 45k but not the wires which looked good). I took out the UIM so I could measure resistance of the spark plug wires and they were all good. I didn't have time to test the coil pack. What would the next steps be after testing/replacing spark plugs, wires, coil pack? Does the UIM gasket have to be changed before reinstalling and what's the torque for those bolts? I purchased the recommended FORD Taurus/Sable 1999-05 Repair Manual Chilton but it's useless as doesn't have my engine in it even though my car is 02 so other than the official Ford service manual is there an online one that someone can recommend? Sorry if I have too many questions but this problem bugs me and I'm pretty sure I can take care of it I just need some advice. Thank you.
 
1 - 1 of 1 Posts
Top