Taurus Car Club of America : Ford Taurus Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I have a 03 vulcan taurus and have a problem. When im driving at any speed and i get the revs up to 4k, the car begins to hesitate and buck violently. Iv'e done research all over the internet where the camshaft sync goes bad after a while. Would a violent bucking/bogging be a symptom of a bad cam sync? or would it be something else?

-Erik
 

·
Premium Member
Joined
·
5,895 Posts
I highly doubt it's the synchronizer. When they go bad they begin by squeaking, then as they get worst will throw the engine light on with a cam sensor code.

When was the last time the fuel filter was changed? If it's really dirty, it could be starving the engine some.
 

·
Registered
Joined
·
405 Posts
does it only do it when it's warmed up? Mine used to do that. I found my thermostat wasn't opening all the way and my guage was a P.O.S.

Changed the thermostat and the problem cleared up.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
I highly doubt it's the synchronizer. When they go bad they begin by squeaking, then as they get worst will throw the engine light on with a cam sensor code.

When was the last time the fuel filter was changed? If it's really dirty, it could be starving the engine some.
fuel filter, fuel pump were replaced. I read somewhere on a google search that when the crank syncro goes really bad it will do this. I also read someone with a similar problem had a dirty sock (the sock like thing that goes over the fuel pump)

again, the dealer replaced the fuel pump. I changed the fuel filter, spark plugs and wires and it still did the obnoxious chugging/bucking at 4k on heavy throttle
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
does it only do it when it's warmed up? Mine used to do that. I found my thermostat wasn't opening all the way and my guage was a P.O.S.

Changed the thermostat and the problem cleared up.
it happens all the time, cold or hot, it doesn't seem to matter. My temp gauge reads fine. Its just really weird, the violent bucking only happens at around 4k. It can probably use a new t-stat, ill give it a try.

keep the suggestions flowing :)
 

·
Registered
Joined
·
191 Posts
I had rough idle and cricket noise, so today I have changed Camshaft Synchronizer with sensor and oil pressure sensor. l still have damned flickering low oil pressure light at low RPM or idle after aggressive driving. But idle is a lot smoother and car seems to be more responsive to the loud pedal.
 

·
Registered
Joined
·
424 Posts
I have a 03 vulcan taurus and have a problem. When im driving at any speed and i get the revs up to 4k, the car begins to hesitate and buck violently. Iv'e done research all over the internet where the camshaft sync goes bad after a while. Would a violent bucking/bogging be a symptom of a bad cam sync? or would it be something else?

-Erik
This is while you are actually moving, right? If the car was in Park or Neutral, then that would be you hitting the rev limiter.
 

·
Premium Member
Joined
·
1,283 Posts
A bad MAF will do the exact same thing. Basically it can produce a reasonably accurate reading with moderate airflow, but when you open the throttle, it does not recognize the increase in airflow, and as a result, the computer does not increase the flow of fuel, and the engine will buck and shake due to lean misfires.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #10 ·
A bad MAF will do the exact same thing. Basically it can produce a reasonably accurate reading with moderate airflow, but when you open the throttle, it does not recognize the increase in airflow, and as a result, the computer does not increase the flow of fuel, and the engine will buck and shake due to lean misfires.
hmm, i might try disconnecting the maf and see what happens
 

·
Registered
Joined
·
619 Posts
Could also be a bad TRS, not telling the PCM you took it out of Park and you're actually hitting the rev limiter.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #12 ·
where is the TRS located?


I pulled the maf plug, and i was able to go wot with a very slight chug at 4,100 or so, but past that everything was good.
 
1 - 12 of 12 Posts
Top