Taurus Car Club of America : Ford Taurus Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
1,318 Posts
Discussion Starter #1
So, tonight, I was driving home from school, and I could smell a very slight burning rubber smell. It was hard to tell though because my nose was stuffy (it's pretty much stuffy all the time when the cold weather comes). On the highway, I couldn't smell it anymore. Then, when I got home, I could smell it again. I popped the hood and got a good wiff of it before it went away.

There was no smoke. The belt seemed fine, it wasn't hot. Nothing seemed wrong under the hood at all. I don't know what it could have been.

Also, ever since there was snow, one of the two tones of my horn don't work. The horns on a G3 are located behind the plastic shield in the left front wheel well, correct? I've had a loose connection somewhere already. Occasionally, that one horn tone wouldn't work, but now, it won't work at all. I think some chunks of packed snow got under there and broke the connection completely (that's just a wild guess though). I did hook a pile of plowed snow when leaving for work. I tried to shovel out a wide enough path but I guess it wasn't enough.

I hate that. I like the sound of the Taurus horn. It sounds pissed off, which is how I feel 90% of the time I used the horn, haha. Now it sounds wimpy with this one single tone.
 

·
Premium Member
Joined
·
8,433 Posts
I smelled a burning plastic smell on my 2000 tec.

I had run over a garbage bag and it melted on my exhaust.

It only smelled for about 10 thousand miles.

The exhaust pipes still have a hard black residue on them though

Mike
:dunno:
 

·
Premium Member
Joined
·
1,318 Posts
Discussion Starter #3
I smelled a burning plastic smell on my 2000 tec.

I had run over a garbage bag and it melted on my exhaust.

It only smelled for about 10 thousand miles.

The exhaust pipes still have a hard black residue on them though

Mike
:dunno:
[/b]
Always a possibility. I mean, to me, it smelled like rubber, but I could barely smell anything, so it was hard to tell. I'll take a look at everything when it's light out.
 

·
Registered
Joined
·
3,748 Posts
My car does that too. I can smell it through the vent. i think it's probably some electrical tape that is getting hot. :dunno:
 

·
Premium Member
Joined
·
1,318 Posts
Discussion Starter #5
When I drove it today I didn't smell anything. Must have been something on the exhaust. I'm gonna keep an eye on it though.

Anyone got info on the horns? I'd rather be sure they are where I think they are before I pull off the wheel and that plastic guard.
 

·
Premium Member
Joined
·
14,126 Posts
I had the burning rubber smell (diffrent than plastic). It was the belt slipping. Happened when the belt got wet. New belt will fix the problem.
 

·
Premium Member
Joined
·
1,318 Posts
Discussion Starter #7
I just got a new belt in July, along with a new tensioner.
 
1 - 7 of 7 Posts
Top