Taurus Car Club of America : Ford Taurus Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
Hey guys I had my car for 2yrs now, I love it, drives so smooth and the engine is real quiet, but I have one problem, the speedo goes crazy when I go ver bumps or go over 55, is there any way to fix this problem?
 

·
Premium Member
Joined
·
15,922 Posts
What year is it?

I would suggest lubing the speedo cable (two spots - behind the cluster and above the tranny) if you have a speedo cable.
 

·
Premium Member
Joined
·
5,758 Posts
This happens a lot on Ford Festiva and Aspire models. The fix is to lube the speedo cable as Qwertz9586 said. Also make sure everything is on tight. I would do this quickly, I have heard of some cables snapping off while driving.
 

·
Premium Member
Joined
·
15,922 Posts

·
Premium Member
Joined
·
15,922 Posts
Not really. I was swapping the speedo and figured I might as well lube it as long as I got the dash apart. I think it's suppose to bounce a couple MPH normally since my old car did the same thing. I got used to it. I don't know how much yours is bouncing though. When using your cruise control, does it feel like the car's jerking back and forth?
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #11 ·
It make a funny noise in the cluster like some thing is rattling, since I've had the car when I'm on the freeway I dont know how fast I'm going cuz it bounces
 

·
Premium Member
Joined
·
112 Posts
I swapped for a SHO cluster, and the tach, gas, and temp gauges work great but the speedo bounces crazy. I'll try to lube it w/ vasaline tomorrow.
 
1 - 13 of 13 Posts
Top