Taurus Car Club of America : Ford Taurus Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
i have a 98 sable dohc,whenever i have my ac on for more then 20 mins its blows the relay... sometime it will last for a few months and sometimes it last for a day :curse:... i took a pic of the fuse box under the hood.... does anyone know where that burned contact leads to??? or if its an easy fix or whatnot... thanx



 

·
Premium Member
Joined
·
14,126 Posts
Yes and with the contact corroded like that it will not make good electrical contact which will keep causing the relay to burn up. Best bet would be to open up the fuse box and fish out the wires. Then mount the relay externally somewhere.
 

·
Premium Member
Joined
·
14,126 Posts
Over time the connection at the relay power gets hot and loosens. This only makes things worse and it will burn them up. It's not the load or the relays, it's the burnt connector now causing the problem.
 

·
Registered
Joined
·
214 Posts
This had happened to me and, like you, it would melt the inductor inside the relay after a month or two. (Has happened twice). I have been going for about 4 months now with putting electric bulb grease inside there and it is working fine.

I would do that before mounting the relay somewhere else since that requires taking the fuse box apart.
 

·
Registered
Joined
·
24 Posts
You can either correct the connection, or set up a remote mount relay like Shoz123 suggests. The loose contacts are causing high resistance...which brings heat into the game. The grease will help as well.
 

·
Premium Member
Joined
·
14,126 Posts
You can twist the offending leg on the relay just a bit so it makes better contact when inserted into the bad connector.
 
1 - 9 of 9 Posts
Top